Should use BITMAPV4HEADER (or BITMAPV5HEADER) on clipboard exchange

RESOLVED DUPLICATE of bug 460969

Status

()

Core
Widget: Win32
RESOLVED DUPLICATE of bug 460969
6 years ago
6 years ago

People

(Reporter: m_kato, Assigned: m_kato)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

6 years ago
When another application pastes DIB format image that copied from Firefox's PNG or other image format, we use BITMAPINFOHEADER.  Since BITMAPINFOHEADER doesn't support alpha channel, it is lost.  (Background of iamge will be black instead of transparent).

We should use BITMAPV5HEADER (or BITMAPV4HEADER) instead of.
(Assignee)

Updated

6 years ago
Summary: Should use BITMAPV5HEADER on clipboard exchange → Should use BITMAPV4HEADER (or BITMAPV5HEADER) on clipboard exchange
(In reply to Makoto Kato from comment #0)
> When another application pastes DIB format image that copied from Firefox's
> PNG or other image format, we use BITMAPINFOHEADER.  Since BITMAPINFOHEADER
> doesn't support alpha channel, it is lost.  (Background of iamge will be
> black instead of transparent).
> 
> We should use BITMAPV5HEADER (or BITMAPV4HEADER) instead of.

Well spotted! :-)

As it turns out, this bug has been known to us for some time now: its a duplicate of bug 460969. That bug has now been assigned to me, so hopefully, it will be fixed soon.

Would you like me to cc you on the other bug so you can keep track of any status updates?

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 460969
BITMAPV5HEADER support patch was proposed in bug 460969 three years and half ago with a comment of "almost every app ignores the alpha".
https://bugzilla.mozilla.org/show_bug.cgi?id=460969#c2
Does this really help?
(In reply to Masatoshi Kimura [:emk] from comment #3)
> BITMAPV5HEADER support patch was proposed in bug 460969 three years and half
> ago with a comment of "almost every app ignores the alpha".
> https://bugzilla.mozilla.org/show_bug.cgi?id=460969#c2
> Does this really help?

Don't worry. I won't shelf the other bug.

The addon-sdk team ran into some problems recently due to this issue, which is what brought bug 460969 back to our attention. As one of the platform devs for that team, it's my responsibility to fix their problem, so I intend to land either the proposed patch or (if necessary) a modified version thereof very soon.

Hope that helps?
You need to log in before you can comment on or make changes to this bug.