Closed Bug 743177 Opened 8 years ago Closed 8 years ago

"Last updated" field of about:addons uses System Regional Settings Format instead of the one defined in Firefox preferences

Categories

(Core :: Internationalization, defect)

11 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 441167

People

(Reporter: max, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

Set Regional Settings on one language (say French) and Firefox locale on another (German).


Actual results:

Firefox 11 is localized so everything conforms with FF prefs, but Date format. When I enter about:addons and check when the addon was "Last Updated" I see Windows Regional Settings Format (French)


Expected results:

Last Updated should show format defined in FF Preferences (current locale)
Are you talking about when searching for add-ons? (Get Add-ons)
If you are, then that content is provided directly by AMO https://services.addons.mozilla.org/en-US/firefox/discovery/addon/quickfox-notes/?src=discovery-featured

In which case the date is provided by: <time datetime="2012-03-06T04:09:24Z">March 5, 2012</time>
I however don't think we properly support <time> yet.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 446510
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core
QA Contact: untriaged → layout.form-controls
Hello Jesper, sorry for waiting, check please the attachment. I'm not sure it is <input> related.And yes, GET ADDONS works as expected.
ah, I see. This is because of nsIScriptableDateFormat http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/extensions/content/extensions.js#1203

And as such have I marked the wrong bug. I have DUP'd this against the correct bug now
Component: Layout: Form Controls → Internationalization
QA Contact: layout.form-controls → i18n
Duplicate of bug: 441167
You need to log in before you can comment on or make changes to this bug.