If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Folder's name with 8-bit chars do not display right

VERIFIED FIXED in M7

Status

MailNews Core
Internationalization
P3
normal
VERIFIED FIXED
19 years ago
9 years ago

People

(Reporter: marina, Assigned: nhottanscp)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Steps to reproduce:
-copy a folder name from 4.6 with 8-bit chars in it to 5.0;
-run Mail and see
//note: folders name with 8-bit chars in it are showing 8-bit chars as dots
(pop3 server,observed with 6/1/99 Win build)
(Assignee)

Updated

19 years ago
Assignee: nhotta → putterman
(Assignee)

Comment 1

19 years ago
Reassigning to putterman@netscape.com.
Scott, is this supposed to work? Marina said it was working last week.

Comment 2

19 years ago
I don't think I touched anything regarding folder names any time recently.  What
do I need to be doing to make this work?
(Assignee)

Comment 3

19 years ago
There are number of Latin1 8 bit related problem started yesterday so this may
be one of them. You can reassign back to me.
I have one question aside from the current problem. Is this supposed to work for
non ascii (e.g. Japanese)?

Updated

19 years ago
Assignee: putterman → nhotta

Comment 4

19 years ago
Reassigning to nhotta based on his last comment.  As far as I know I haven't
touched this code.  However, I haven't done anything to make this work or not
work for Japanese so this could still all be my fault, if it was never working
before.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Target Milestone: M7
(Assignee)

Comment 5

19 years ago
I think this is a part of Latin1 8bit problems caused by nsString. Please verify
for folder name with Latin1 8bits.
In addition, please try Japanese folder name and report if any problem to
putterman@netscape.com as a separate bug, thanks.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

19 years ago
Folder's name that contains non-ascii chars are displaying correctly in 6/8/99
build, marking as verified.

Comment 7

19 years ago
Marina, does your test include Japanese folder names, too?

Updated

19 years ago
Status: VERIFIED → REOPENED

Comment 8

19 years ago
It doesn't look like Japanese folder names are supported
currently in that they seem to be interpreted as Latin 1 or
UTF-8.

There is also a special problem with 0x5c JPN
names in that folders containing such names do not show up
at all.

Updated

19 years ago
Resolution: FIXED → ---

Comment 9

19 years ago
Naoki, this is supposed to be system dependent. Right?
So on US systems, we need to assume the system charset
there in names but on JPN systems, we need to assume
whatever the locale charset is, e.g. Shift_JIS (Mac/Win),
EUC-JP or Shift_JIS (Unix lcoales).
(Assignee)

Comment 10

19 years ago
I am not sure about the implementaion detail of this. As I mentioned before, I
think it's better to create a separate bug for the problem you mentioned. We can
input the i18n info to Scott Putterman to solve the problem.
(Reporter)

Comment 11

19 years ago
I filed this bug originally for Latin-1, so i verified it for Latin-1. When i'll
test on JA win and in case i'll see the problem i'll open a bug for JA.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

19 years ago
Marking as FIXED.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 13

19 years ago
Since I looked at Japanese folder names already.
I'll file a new bug on that.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.