Mail database corruption upon hitting partition limits

VERIFIED DUPLICATE of bug 55814

Status

MailNews Core
Database
--
critical
VERIFIED DUPLICATE of bug 55814
17 years ago
10 years ago

People

(Reporter: wvholst, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2 i686; en-US; 0.8) Gecko/20010216
BuildID:    2001021614

The partition with /home on it got filled up to 100% of its capacity while
Mozilla Mail was open. The second it got full Mozilla started trashing its mail
database, its settings and all its bookmarks. The mail folders are not really
lost, nonetheless they are invisible and you have to force Mozilla to use the
old directories again for each account.

Reproducible: Didn't try
Steps to Reproduce:
1.Open mozilla mail
2.Fill up your /home partition to its limit
3.See Mozilla start to trash mail.
4.Close Mozilla
5.Start Mozilla again.

Actual Results:  See the description.

Expected Results:  Mozilla should have died gracefully stating that it could not
update its files because ther was no space left on the storage device.

This is killing for the casual user. Messing around in your ~/.mozilla directory
isn't something you can expect from a newbie.

Comment 1

17 years ago
This has apparently been fixed. Please try a more recent build. (I don't think
it was in 0.8.1)

*** This bug has been marked as a duplicate of 55814 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Forgot to mention: if this does reoccur (or you're not using POP), please reopen
this bug.
verified dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.