Installing new dictionaries leads to 404 page

RESOLVED FIXED

Status

--
critical
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: versluis2000, Assigned: clouserw)

Tracking

({regression})

Details

(URL)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

I was trying to install a new dictionary from the Spell Checking drop down. This is from an email composition window. This kindly supplied a list of installed dictionaries, and a link to "install new dictionary". I clicked that.


Actual results:

This took me to a new Thunderbird tab (nice!) with a 404 page, saying add-on not found. It's not a biggie, since there was a link on the left hand side which pointed me to the right direction. However, being an occasional software developer myself, I thought I'd let you guys know about this.


Expected results:

The link should have gone to the correct place immediately, without the 404 page in the middle.

Comment 1

7 years ago
(In reply to Jay Versluis from comment #0)
Confirmed here:
User Agent: Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20120327 Thunderbird/11.0.1
Application Build ID: 20120327115527

Write ➯ Options ➯ Spell Checking ➯ Language ➯ Download more dictionaries... (error page).
Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0

This also fails in Firefox, so it's probably a core bug.
Firefox: Right click textarea -> Languages -> Add Dictionaries...

Looks like it should now go to https://addons.mozilla.org/[language]/[application]/language-tools/
Status: UNCONFIRMED → NEW
Component: Preferences → Spelling checker
Ever confirmed: true
Product: Thunderbird → Core
QA Contact: preferences → spelling-checker
Version: 11 → unspecified

Updated

7 years ago
Severity: normal → critical
Component: Spelling checker → Public Pages
Keywords: regression
Product: Core → addons.mozilla.org
QA Contact: spelling-checker → web-ui
This is a major regression in AMO link functionality, breaking all older versions and current versions of Firefox & Thunderbird. It looks like it could be fixed by a redirect from

https://addons.mozilla.org/%LOCALE%/%APP%/dictionaries/

to

https://addons.mozilla.org/%LOCALE%/%APP%/language-tools/

but I believe that if this is the new location then new versions of Firefox, Thunderbird & all should be updated to point to this new location rather than the old one.
tracking-firefox11: --- → ?
tracking-firefox12: --- → ?
(Assignee)

Comment 4

6 years ago
https://github.com/mozilla/zamboni/commit/a0b6ec77ca49e6fdb8b1758d25b7676ff98d8e22
Assignee: nobody → clouserw
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

6 years ago
I added a redirect back in for /dictionaries/  It'll be on addons-dev.allizom.org in a second.
I've temporarely changed setting spellchecker.dictionaries.download.url in Thunderbird to addons-dev.allizom.org and can confirm it works! Good job. Don't know how to test this in Firefox, because I can't find the pref there...

Updated

6 years ago
Duplicate of this bug: 745434

Comment 8

6 years ago
We're a week out from Firefox 12's release. It sounds like this can be at least temporarily resolved server side. Please email release-mgmt@mozilla.com today if you still believe this needs to go into our final beta. Otherwise, we'll first resolve this for FF13 if any further action is necessary.
status-firefox11: --- → wontfix
status-firefox12: --- → wontfix
tracking-firefox11: ? → -
tracking-firefox12: ? → -
tracking-firefox13: --- → +

Comment 9

6 years ago
Just tested - everything looks fine to me on FF13. This must have been rolled out to production.
tracking-firefox13: + → -
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.