SUMO Image Attachment close (X) button hard to see

RESOLVED FIXED in 2012.10

Status

support.mozilla.org
General
P2
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Terry R., Assigned: rehan)

Tracking

unspecified
2012.10

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=contributor c=general p=1)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 612909 [details]
Image attachment window showing barely visible close button

Example:  https://support.mozilla.org/en-US/questions/924605

The 3rd reply by Verdi has an image.  When clicked a larger view pops over, but the blue heading color almost completely masks the X to close the window.  I tried going back (ALT-left arrow), pressing ESC, but nothing worked.  I then realized a barely visible X in the top right corner.  

The X should be a distinct color.
Thank you for reporting this. I wholeheartedly agree. I've been hating that X for a long time now, especially since it's the only way to exit the image viewer.

I can't even click an area on the outside of the image to escape the image viewer or use the ESC key. I especially hate when the image is so large I have to scroll all the way to the right, just to see the close button then finally click it.

In addition to changing the image attachment header color, can we change this so that clicking outside of the image closes the image viewer? Or that it respects the ESC key? Or we add an additional close button to the left corner of the header? Or all of the suggested? :)

This also affects the Additional System Details window reached from the "More system details" link:
https://support.mozilla.org/en-US/questions/924605#more-system-details

And the Get email updates & Report abuse windows.

Suggestion to change close button character to image:
What angers me more about this issue is that I do not have the supported font for that close button and have seen a unicode character ever since the forum upgrade in August 2010. Screenshot: http://i.imgur.com/7nekP.png 

It apparently uses the Heavy multiplication X character from the Dingbats font. Any reason we chose to go with that over an image? I'm wondering if people in other countries are seeing this broken icon b/c they don't have this font as well. I'm on Win XP. Is this a default windows font? Also I tried searching to download fonts for this, but did not download them as most of them might be bundled with malware, not free, etc. :/

I'm mentioning this here in case this bug becomes the groundfloor for redoing the close button. Let me know if I should file separately.

Updated

6 years ago
Priority: -- → P2
Whiteboard: u=contributor c=questions p=
Target Milestone: --- → 2012.10
Whiteboard: u=contributor c=questions p= → u=contributor c=questions p=1
This style is shared by all the modals across the site.
Component: Questions → General
QA Contact: questions → general
Whiteboard: u=contributor c=questions p=1 → u=contributor c=general p=1
Ricky, what do you think, can we do "ESC" to close the modal in this bug too?
(In reply to Kadir Topal [:atopal] from comment #3)
> Ricky, what do you think, can we do "ESC" to close the modal in this bug too?

Yes, that is just a configuration option to the modal implementation.
(Assignee)

Updated

6 years ago
Assignee: nobody → rdalal
(Assignee)

Comment 5

6 years ago
Landed:

https://github.com/mozilla/kitsune/commit/754bc1fe44d9629d91a838224414d3b78da635d1
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
I'll make sure to push this today.
Pushed to production just now.
You need to log in before you can comment on or make changes to this bug.