Status

Developer Services
General
--
major
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: jhford, Assigned: cshields)

Tracking

Details

During this morning's downtime, HG started spewing nagios warnings and returning http 500s.  Filing this bug as major instead of blocker because the tree is already closed, but this does block re-opening the tree.
(Assignee)

Comment 1

6 years ago
try's pushlog is clogged again..  VYV03354@nifty.ne.jp had 2 changesets assigned to the same push in pushlog, and the timing of the pushlog entry coincides with the rest of hg freaking out.

Recommendation is to just reset try at this point since we are in a downtime anyway, and try should be reset as often as we can get away with.
I am not sure what info in try needs to be kept.  

Can we make a complete backup of the current repository including pushlog in whatever state it's in before resetting it?
I just confirmed that the backup of old try is actually no longer important, we don't need to keep a backup of it
(Assignee)

Comment 4

6 years ago
try has been reset, and the mirror resynced.  This caused our outage problem to go away.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Component: Server Operations: Developer Services → General
Product: mozilla.org → Developer Services
You need to log in before you can comment on or make changes to this bug.