Firefox 11.0's HTML5 offline web app bug

RESOLVED DUPLICATE of bug 734062

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 734062
6 years ago
6 years ago

People

(Reporter: Wei Lou, Unassigned)

Tracking

11 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19

Steps to reproduce:

Now I provide detailed steps to reproduce this bug:

This bug still exists on Firefox 11. Safari 5.1.5 on PC and Safari on iOS 5.1 can both work fine.

1, Set MIME type "text/cache-manifest" to .appcache file on server.

2, Create an HTML file with codes below:

<!DOCTYPE html>
<html manifest="offline.appcache">
	<meta charset="utf-8">
	<title>A Firefox's Bug</title>
	<link href="index.css" rel="stylesheet">
	ABC

3, Create a CSS file index.css with codes below:

@charset "UTF-8";

body {
	color: red;
}

4, Create an offline.appcache file with codes below:

CACHE MANIFEST
# v1
index.css

5, Upload these 3 files to server.

6, Open your Firefox 11 stable version and then access to your page which is on server.

7, you should see characters "ABC" are in red.

8, Close this page's tab on Firefox.

9, Change the codes in index.css file with codes below:

@charset "UTF-8";

body {
	color: blue;
}

10, Upload this CSS file to server.

11, Change the codes in offline.appcache file to codes below:

CACHE MANIFEST
# v2
index.css

12, Upload offline.appcache file to server.

13, Access to your page which is on server.

14, Wait several minutes and then close this page's tab on Firefox.

15, Access to your page which is on server.

You should see characters in page are in blue. But what you see on Firefox 11 is that characters are still in red. This is a bug.

If anyone don't believe this is a bug relevant to HTML5's offline web app feature on Firefox, follow the reproduce steps provided by me. And then leave comment.

Mozilla should fix this bug ASAP.
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 734062
You need to log in before you can comment on or make changes to this bug.