Closed Bug 743297 Opened 11 years ago Closed 10 years ago

On startup first HTML page has default zoom level instead of stored user zoom level, after pressing F5 it is ok

Categories

(Firefox :: General, defect)

11 Branch
x86_64
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox20 --- unaffected
firefox-esr17 --- wontfix

People

(Reporter: Martin.firefox.Maurer, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

I have a "big" screen (24 inch) with high resolution (1980 x 1200). 
Windows Vista 64 bit.

My default page on startup of Firefox 11 is a local HTML page 
(stored on local hard disk). I have increased the size of the page 
by pressing Ctrl and Mouse-Wheel to fit my screen. 
It was working with previous version of Firefox on same computer.

When i open Firefox or press Ctrl-N to open a new window,
the HTML page is displayed in a very small font, complete page is around half
of my screen. When pressing F5 the same page is redisplayed, but now in
bigger font, filling my complete page.


Actual results:

Local HTML page is displayed with small font and size is half of the screen.
When pressing F5 it is ok.


Expected results:

Local HTML page is displayed with bigger font and filling the complete screen.
This is not a recent regression.
I can reproduce Firefox3.0.19-Nightly14.0a1.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I can't reproduce on the Mac nightly.  The zoom code has changed recently, so maybe that fixed it.  Do you see the problem on nightly?
Component: Untriaged → General
This was fixed in Firefox19+ by Bug 715402.
Status: NEW → RESOLVED
Closed: 10 years ago
Depends on: 715402
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.