Last Comment Bug 743414 - Compartments and window objects leak when opening links in new windows with Restartless Restart 8 and SmartSearch 3.19
: Compartments and window objects leak when opening links in new windows with R...
Status: RESOLVED FIXED
:
Product: Tech Evangelism
Classification: Other
Component: Add-ons (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: LeakyAddons ZombieCompartments
  Show dependency treegraph
 
Reported: 2012-04-06 18:45 PDT by ferongr
Modified: 2012-08-29 20:42 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description ferongr 2012-04-06 18:45:22 PDT
STR:

1. Install Restartless Restart 8 [1] and SmartSearch 3.19 [2]. Restart.
2. Open about:compartments. Note existing compartments.
2. Go to any website.
3. Right-click on a link an "Open Link in New Window".
4. Close the new window and its originating tab, and refresh about:compartments a few times. You should see ghost windows and zombie compartments from the website.
5. Disable Restartless Restart and refresh about:compartments.
6. The zombies and ghosts are dead.

[1] https://addons.mozilla.org/en-US/firefox/addon/restartless-restart/
[2] https://addons.mozilla.org/en-us/firefox/addon/smartsearch/
Comment 1 ferongr 2012-04-06 18:47:00 PDT
Forgot to mention, this is on the 2012-04-06 Nightly.
Comment 2 Justin Lebar (not reading bugmail) 2012-04-07 07:06:19 PDT
You need both restartless restart and smartsearch to see this leak?
Comment 3 ferongr 2012-04-07 07:13:31 PDT
Yes.
Comment 4 Andrew Williamson [:eviljeff] 2012-04-12 11:06:20 PDT
Confirming the issue.  And also that disabling either addon stops the leak

erik: would you mind having a look in restartless restart to see if you can establish where the leak is coming from?
Comment 5 Jorge Villalobos [:jorgev] 2012-04-26 15:36:15 PDT
Note that bug 743215 has similar steps to reproduce (open a new window), and both add-ons are authored by the same developer, so this may be related to common code in both add-ons.
Comment 6 Nicholas Nethercote [:njn] 2012-08-29 20:42:25 PDT
(In reply to Jorge Villalobos [:jorgev] from comment #5)
> Note that bug 743215 has similar steps to reproduce (open a new window), and
> both add-ons are authored by the same developer, so this may be related to
> common code in both add-ons.

I just tried with a FF18 trunk build and couldn't reproduce, so I'm guessing that Firefox 15 fixes this problem, even though it didn't fix bug 743215.

Note You need to log in before you can comment on or make changes to this bug.