javascript console hangs when entering "document.body.innerHTML."

RESOLVED FIXED in Firefox 17

Status

()

Firefox
Developer Tools: Console
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Laxminarayan G Kamath A, Unassigned)

Tracking

({hang, regression})

7 Branch
Firefox 17
hang, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 775812])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:13.0a1) Gecko/20120201 Firefox/13.0a1
Build ID: 20120201031146

Steps to reproduce:

1) Opened the URL http://en.wikipedia.org/wiki/Latin-derived_alphabet
2) opened the web console (ctrl-shift-k)
3) entered document.body.innerHTML. (note the dot at the end)


Actual results:

browser hung indefinitely

dont know if this hapens for other sites ..


Expected results:

browser should have continued working ..

Comment 1

5 years ago
I can reproduce on other page such as https://developer.mozilla.org/En/Code_snippets .
This happens since Firefox7.

And I got  Unresponsive script dialog  as follow

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.
Script: resource:///modules/AutocompletePopup.jsm:198

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.
Script: resource:///modules/AutocompletePopup.jsm:300

Regression window:
Cannot reproduce:
http://hg.mozilla.org/mozilla-central/rev/0577771f2065
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110624 Firefox/7.0a1 ID:20110624082701
Can reproduce:
http://hg.mozilla.org/mozilla-central/rev/0421a3198a3c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110624 Firefox/7.0a1 ID:20110624115816
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0577771f2065&tochange=0421a3198a3c

Suspected: Bug 651501
Blocks: 651501
Status: UNCONFIRMED → NEW
Component: Untriaged → Developer Tools: Scratchpad
Ever confirmed: true
OS: Linux → All
QA Contact: untriaged → developer.tools.scratchpad
Version: 13 Branch → Trunk

Updated

5 years ago
Component: Developer Tools: Scratchpad → Developer Tools: Console
QA Contact: developer.tools.scratchpad → developer.tools.console
Hardware: x86 → All

Updated

5 years ago
Severity: normal → critical
Keywords: hang, regression
Version: Trunk → 7 Branch

Comment 2

5 years ago
I experienced the same issue with "document.body.outerHTML.".

Comment 3

5 years ago
I tried both: 
document.body.outerHTML.
and
document.body.innerHTML.
on https://developer.mozilla.org/En/Code_snippets with Nightly 17.0a1 (2012-08-01) & Windows XP mode and couldn't reproduce.

Then tried both on the same website, however this time on FF v14.0.1, Windows 7 Ultimate, and was able to reproduce both times.

The first time I terminated FF soon after. On the second time I got the unresponsive script warning, with error message:

"A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: resource:///modules/AutocompletePopup.jsm:198"
Thanks for testing. This is fixed by bug 775812.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Depends on: 775812
Resolution: --- → FIXED
Whiteboard: [fixed by bug 775812]
Target Milestone: --- → Firefox 17
You need to log in before you can comment on or make changes to this bug.