Last Comment Bug 743428 - make package fails on platforms where profiler is not available
: make package fails on platforms where profiler is not available
Status: RESOLVED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Installer (show other bugs)
: Trunk
: All OpenBSD
: -- normal (vote)
: Firefox 14
Assigned To: Landry Breuil (:gaston)
:
Mentors:
Depends on:
Blocks: 713132 734335 744026
  Show dependency treegraph
 
Reported: 2012-04-07 01:39 PDT by Landry Breuil (:gaston)
Modified: 2012-04-10 08:57 PDT (History)
4 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
package profiler.xpt only if MOZ_ENABLE_PROFILER_SPS is set (1.02 KB, patch)
2012-04-07 01:45 PDT, Landry Breuil (:gaston)
mh+mozilla: review+
bugzillamozillaorg_serge_20140323: feedback+
Details | Diff | Splinter Review
package profiler.xpt only if MOZ_ENABLE_PROFILER_SPS is set (2.61 KB, patch)
2012-04-09 00:27 PDT, Landry Breuil (:gaston)
no flags Details | Diff | Splinter Review

Description Landry Breuil (:gaston) 2012-04-07 01:39:50 PDT
Since landing of #713132, make package fails on OpenBSD (and probably all other platforms where the profiler is not enabled). Patch in a second.
Comment 1 Landry Breuil (:gaston) 2012-04-07 01:45:02 PDT
Created attachment 613076 [details] [diff] [review]
package profiler.xpt only if MOZ_ENABLE_PROFILER_SPS is set
Comment 2 Serge Gautherie (:sgautherie) 2012-04-07 06:02:59 PDT
Comment on attachment 613076 [details] [diff] [review]
package profiler.xpt only if MOZ_ENABLE_PROFILER_SPS is set

I assume that should be it.
Comment 3 Mike Hommey [:glandium] 2012-04-09 00:15:15 PDT
Comment on attachment 613076 [details] [diff] [review]
package profiler.xpt only if MOZ_ENABLE_PROFILER_SPS is set

Review of attachment 613076 [details] [diff] [review]:
-----------------------------------------------------------------

r+, but please patch b2g/installer/package-manifest.in and mobile/android/installer/package-manifest.in, too.
Comment 4 Landry Breuil (:gaston) 2012-04-09 00:27:55 PDT
Created attachment 613244 [details] [diff] [review]
package profiler.xpt only if MOZ_ENABLE_PROFILER_SPS is set

Sure, setting checkin-needed for that patch fixing the 3 files
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-04-09 15:42:44 PDT
Looks like this already landed without any notes in this bug.
http://hg.mozilla.org/integration/mozilla-inbound/rev/cdd4141ec53b
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2012-04-10 01:45:11 PDT
(In reply to Ryan VanderMeulen from comment #5)
> Looks like this already landed without any notes in this bug.
> http://hg.mozilla.org/integration/mozilla-inbound/rev/cdd4141ec53b

Yes, sorry. I was going to note it, but lost track...

Note You need to log in before you can comment on or make changes to this bug.