Last Comment Bug 743451 - test_keys.js fails in some time zones.
: test_keys.js fails in some time zones.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Masatoshi Kimura [:emk]
:
:
Mentors:
Depends on: 647568
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-07 08:34 PDT by Masatoshi Kimura [:emk]
Modified: 2012-04-10 08:42 PDT (History)
3 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
workaround for ISO date parsing bug (1.00 KB, patch)
2012-04-07 08:42 PDT, Masatoshi Kimura [:emk]
bent.mozilla: review+
Details | Diff | Splinter Review

Description Masatoshi Kimura [:emk] 2012-04-07 08:34:05 PDT
|new Date("1971-01-01")| and |new Date("1971-01-01T01:01:01")| will be parsed inconsistently because of bug 647568 (the former will be parsed as UTC and the latter will be parsed as local time).
Comment 1 Masatoshi Kimura [:emk] 2012-04-07 08:42:02 PDT
Created attachment 613113 [details] [diff] [review]
workaround for ISO date parsing bug

Workaround until bug 647568 is fixed.
Comment 2 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-04-07 10:41:37 PDT
Comment on attachment 613113 [details] [diff] [review]
workaround for ISO date parsing bug

Thanks!
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-04-09 15:47:11 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/81012bc3fa5d

Note You need to log in before you can comment on or make changes to this bug.