If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Drag and Drop Displays Messages before dropped (display messages on mouseup, not on click)

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Ben Ruppel, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
Future
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8.1)
BuildID:    2001033020

In the three-pane (alternative layout, other not confirmed), if you drage a
message from the messages list to the viewing area, the message is displayed
before it is dropped.  Weird.

Reproducible: Always
Steps to Reproduce:
1.Open 3-pane
2.click on a message
3.drag it to the viewing area

Actual Results:  Message displays before the mouse button is released.

Expected Results:  Message only displays once it is dropped.

Sorry if this is an unneccesary bug that someone's already working on.

Comment 1

17 years ago
Not sure what the bug is here. Since you select the message it automatically
displays it. Thus it is displayed before you drop it. Or am i not understanding
the bug properly.
(Reporter)

Comment 2

17 years ago
Okay, this is just weird behavior and it has gotten better since the reporting.
 I think it's just not as easy to do now that mailnews has gotten faster.  Try
clicking on a message, holding down the mouse button, and dragging elsewhere
(like out of the 3-pane, or into the folders pane) very quickly.  The message
won't display until you release of until you drag the message over the message
display pane.  Not a very important bug....

Comment 3

17 years ago
What I see with this is that when you click and hold on the message when it is
not previously selected, the message header loads, and "Loading document..." is
displayed on the toolbar. This happens in either 2-pane or 3-pane mode. I don't
know if this is intended to happen this way, but this is not the original bug,
marking this WORKSFORME. If it's not the intended way to function, another bug
needs opened on it.

Moz Build: 2001053104 Win32
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9+) Gecko/20010531
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
The message *always* gets displayed when you select it.  That is the way it is
intended to work.  I don't know how else we could implement it, since selection
always does the default action, and in this case, that is to display the message.
Note, that if you use multiple selection using CTRL, we don't display each new
message, but that is because CTRL is a modifier.
Status: RESOLVED → VERIFIED
reopening.

here's what 4.x does:  it does not display the message until mouseup.

so if you are displaying message X and then try to click and drag message Y to
the trash, it should not display message Y.
Status: VERIFIED → UNCONFIRMED
Keywords: 4xp
Resolution: WORKSFORME → ---
accepting, but futuring.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Drag and Drop Displays Messages before dropped → Drag and Drop Displays Messages before dropped (display messages on mouseup, not on click)
Target Milestone: --- → Future
(Reporter)

Comment 7

16 years ago
Marking worksforme, as I can't reproduce the bug any more.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 8

16 years ago
Marking verified worksforme based on reporter's last comments
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.