Cursor blinks frenziedly when mouse sweeps over links

RESOLVED FIXED in mozilla1.2alpha

Status

()

--
trivial
RESOLVED FIXED
18 years ago
13 years ago

People

(Reporter: doctor__j, Assigned: saari)

Tracking

Trunk
mozilla1.2alpha
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; 0.8.1)
BuildID:    2001040120

The cursor in the URL bar blinks (in other words, redraws) *more* rapidly when
the mouse is placed over URL links and leaving URL links.

Reproducible: Always
Steps to Reproduce:
1. Find a page (any page) with a link shown on screen.
2. Clink on location bar so the cursor is shown on it.
3. Move your mouse over the links and away from the links and see the cursor
redraws as you do that.

Expected Results:  Cursor blink rate should stay cool and blink *regularly*.

When a webpage is being laoded (like downloading the graphics), the cursor would
blink crazily on the location bar too...

Maybe a screen/cursor redraw problem ??
seeing this on Linux too.
OS: Windows 98 → All

Comment 2

18 years ago
I don't see this on Mac, and I'm not sure where it should go. Punting to Event 
Handling for starters.
I'm seeing very fast/uneven cursor blinking in freebsd (even when just clickin
on the location bar and letting it sit, though it's more even then).  Sounds
like something is fubar'd.  It happened in the last week or so.  Confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
Not seeing this on Linux. 2001-10-12-0.9.5.

Gerv

Comment 5

17 years ago
--> Event Handling (2nd attempt)
Assignee: mpt → joki
Component: User Interface Design → Event Handling
QA Contact: zach → madhur
(Assignee)

Comment 6

17 years ago
annoying, but not 1.0 
Target Milestone: --- → mozilla1.2

Updated

17 years ago
QA Contact: madhur → rakeshmishra

Updated

16 years ago
QA Contact: rakeshmishra → trix

Comment 7

15 years ago
.
Assignee: joki → saari
QA Contact: trix → ian

Comment 8

15 years ago
Reporter, are you still seeing this ? I can't reproduce in Firefox 20040206 on
Windows NT.
(Reporter)

Comment 9

15 years ago
The bug still exists as verified using Mozilla nightly build 2004022716.

Comment 10

15 years ago
Confirmed to exist in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b)
Gecko/20040421.

I wasn't sure what the Reporter meant at first, but after futzing around, I
managed to figure it out.

1.  Visit a page that has a hyperlink.
2.  Click on the URL location bar (usually twice), so that the input cursor appears.
3.  Move/hover the mouse back and forth between the hyperlink itself and a
non-hyperlinked area.
4.  The text input cursor will blink erratically.

Here's another step-through test, which is even more interesting:

1.  Visit a page that has a TEXTAREA input box.
2.  Click inside of the TEXTAREA box, so that the input cursor appears.
3.  Move the mouse inside and outside the TEXTAREA input box, semi-quickly.
4.  The cursor will blink/flash erratically, and will also commonly not blink at
all (I tend to believe it IS blinking, but that the start of the blink happens
to be the cursor being shown, so it looks as if it's not blinking).

All of these sorts-of quirks are probably due to whatever portability engine the
Mozilla folks are using to build across different platforms (just a shot in the
dark here).  I still wonder why they don't use wxWindows... sigh.

Comment 11

14 years ago
Bug has sat idle/unlooked at for almost a year.

Confirming that this bug still exists as of the latest Mozilla release (1.0).

Comment 12

14 years ago
*** Bug 266196 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
*** Bug 295120 has been marked as a duplicate of this bug. ***
I can see the bug in older builds, but not anymore in the 2006-04-18 trunk build on windows. I think this is fixed by bug 287813.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Depends on: 287813
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.