radio buttons with display:none lose grouping

VERIFIED DUPLICATE of bug 34297

Status

()

Core
CSS Parsing and Computation
VERIFIED DUPLICATE of bug 34297
17 years ago
17 years ago

People

(Reporter: unapersson, Assigned: Pierre Saslawsky)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When a radio button is hidden with "display: none" it loses its association with other radio buttons in the same group.
(Reporter)

Comment 1

17 years ago
I've got a testcase but can't attach it because of proxy problems, but will try and attach one later. The problem revealed itself when using radio buttons with the same name across multiple tabs which were switched on and off using "display: none". A radio button appearing on a tab with display: none set, would lose it's value in favour of the radio button in the currently displayed panel.
This is probably a dup of the general bug about form elements losing state when
they or their containers are set to display:none
(Reporter)

Comment 3

17 years ago
Yes, that sounds like it. Do you have a bug number? I've got a testcase I can
file against it.

*** This bug has been marked as a duplicate of 34297 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
verifying duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.