If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

websocket tab disconnect

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: torleifw, Unassigned)

Tracking

11 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.151 Safari/535.19

Steps to reproduce:

Create multiple instances (tabs) of the same websocket. Disconnecting or closing one tab will close all other connections. 


Actual results:

All pages & sockets called the socket.onclose() function, closing all connections on all tabs.


Expected results:

Only the disconnected or closed tab should call the onclose function. Google Chrome handles this event properly.
(Reporter)

Comment 1

6 years ago
Update: The closed sockets was caused by a server returning invalid frames. While this means there may be a bug that could close all open sockets on firefox at one time, it's probably not big a deal.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.