Back button does not dismiss the keyboard in Top Sites section

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: paul.feher, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox15 affected, firefox16 affected, firefox17 affected, fennec+)

Details

(Reporter)

Description

7 years ago
Nightly Fennec 14.0a1 (2012-04-09)
Device: HTC Desire Z
OS: Android 2.3.3

Steps to reproduce:
1. Tap on the url bar to open the awesome bar in the Top Sites section 
2. Tap on the system back button

Expected:
The keyboard is dismissed and the Top Sites section is displayed.

Actual
The view is returns to the home screen.
WFM same build, GN 4.0.4
(Reporter)

Comment 2

7 years ago
This is also reproducible on Samsung Galaxy S2 (Android 2.3.4)  but not reproducible on Galaxy Nexus (Android 4.0.2)
Hi Paul, is the VKB still up after returning to the home screen?  Could we get either a screenshot or a movie on what you see please?

Comment 4

7 years ago
WFM on HTC Sensation, Android 2.3.4.  the VKB is dismissed when back'ing to about:home.
(Reporter)

Comment 5

7 years ago
The video for this issue:
http://youtu.be/07sBcwLO-pY

Like you can see in the video above this issue refers to the fact that in the Top Sites section you can't dismiss only the keyboard using the back button like in the Bookmarks and History sections. Like i said in comment 2 this issue is not reproducible for Galaxy Nexus (Android 4.0.2).
(Reporter)

Comment 6

6 years ago
The issue is also reproducible on:
Firefox Mobile Native 15.0b5 build1 (2012-08-15)
Device: Samsung Galaxy Tab (Android 3.1)
tracking-fennec: --- → ?
status-firefox15: --- → affected
status-firefox16: --- → affected
status-firefox17: --- → affected
Lucas - Low priority, but might be part of the UI cleanup. Try to get a device to reproduce it first.
Assignee: nobody → lucasr.at.mozilla
tracking-fennec: ? → -
(In reply to Paul Feher from comment #0)
> Nightly Fennec 14.0a1 (2012-04-09)
> Device: HTC Desire Z
> OS: Android 2.3.3
> 
> Steps to reproduce:
> 1. Tap on the url bar to open the awesome bar in the Top Sites section 
> 2. Tap on the system back button
> 
> Expected:
> The keyboard is dismissed and the Top Sites section is displayed.
> 
> Actual
> The view is returns to the home screen.

IIRC, this behaviour is the intended design as you can easily dismiss the keyboard by panning the list. Maybe UX guys want revisit this decision? Ian, Madhava?

Comment 9

6 years ago
(In reply to Lucas Rocha (:lucasr) from comment #8)
> (In reply to Paul Feher from comment #0)
> > Nightly Fennec 14.0a1 (2012-04-09)
> > Device: HTC Desire Z
> > OS: Android 2.3.3
> > 
> > Steps to reproduce:
> > 1. Tap on the url bar to open the awesome bar in the Top Sites section 
> > 2. Tap on the system back button
> > 
> > Expected:
> > The keyboard is dismissed and the Top Sites section is displayed.
> > 
> > Actual
> > The view is returns to the home screen.
> 
> IIRC, this behaviour is the intended design as you can easily dismiss the
> keyboard by panning the list. Maybe UX guys want revisit this decision? Ian,
> Madhava?

(For reference, it was bug 700951)
Ian, what do you think?
Flags: needinfo?(ibarlow)
That's correct, the back button should go back a step instead of dismissing the keyboard. 

However, I am seeing some problems in the awesomescreen's behaviour on Nightly at the moment:

1. Back button behaviour is inconsistent. Tapping Back on the top sites tab goes back a page, while tapping back on Bookmarks or History tabs dismisses the keyboard. It should always go back a page. 

2. The back button behaviour we want is a little misleading on phones with soft buttons, since the "back" button turns into a "keyboard dismiss" button when the keyboard is up. So I can see the confusion of tapping the keyboard dismiss button and wondering why it took me back a page.

3. The keyboard should be dismissed as soon as you start scrolling your awesomescreen results. It isn't doing that right now, which can make it feel like there is no clear way to dismiss the keyboard.
Flags: needinfo?(ibarlow)

Updated

6 years ago
tracking-fennec: - → ?
tracking-fennec: ? → +

Updated

6 years ago
Assignee: lucasr.at.mozilla → nobody

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.