Edit Profile link is too hard to find

VERIFIED FIXED in 2012-04-25

Status

Participation Infrastructure
Phonebook
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

other
2012-04-25
Bug Flags:
in-testsuite ?

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
The edit profile link is only visible in the profile page. Since there's so much more meta data that can be added, it should be easier to find.
(Reporter)

Comment 2

6 years ago
Forget about that last pull request. Here's the real one: 

https://github.com/mozilla/mozillians/pull/209

Comment 3

6 years ago
Commits pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/6e5e41d676cfe3facfe2717dc97ea28fec93efe5
Clean up nav bar and uplevel Edit Profile button. bug 743709

https://github.com/mozilla/mozillians/commit/3b33cc5a08523197e0005df5d7d3ea59423fcffb
Merge pull request #209 from sammybahamas/master

Clean up nav bar and uplevel Edit Profile button. bug 743709
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Created attachment 614217 [details]
qa - verified

QA verified on stage and dev - account holders can edit their account via the menu drop down.

Updated

6 years ago
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
This doesn't work for users without usernames
Assignee: mozaakash → owen
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 6

6 years ago
Commits pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/d3bc0e358d5bd49b470d3c0ab82bd8a99abe1588
Bad username logic in base template. Fix bug743709

https://github.com/mozilla/mozillians/commit/1eb19f36ec5c139673cfb4a75c98e302c58bf219
Merge pull request #215 from tallowen/username-dropdown

Bad username logic in base template. Fix bug743709

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Created attachment 615399 [details]
qa - reopened - username not set

I'm not sure if this was intended - when a username is not set by the account holder the generated-hash is displayed in the upper right-hand corner.

Updated

6 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Thanks owen - I hadn't realized your latest tweak was only on dev, sorry for reopening the bug. Bumping to QA verified on dev - when a username contains a u/<hash> the string is replaced  with 'Options.'

https://github.com/mozilla/mozillians/commit/d3bc0e358d5bd49b470d3c0ab82bd8a99abe1588#L0R66
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Status: RESOLVED → VERIFIED

Updated

6 years ago
Assignee: owen → nobody
Component: mozillians.org → Phonebook
Product: Websites → Community Tools
QA Contact: mozillians-org → phonebook
Whiteboard: [rel:04/18/2012] → [rel:25/04/2012]
Target Milestone: --- → 2012-04-25
Version: unspecified → other

Updated

6 years ago
Whiteboard: [rel:25/04/2012]
You need to log in before you can comment on or make changes to this bug.