Browser will not browse to any URL

VERIFIED INVALID

Status

Core Graveyard
Java: OJI
--
blocker
VERIFIED INVALID
17 years ago
7 years ago

People

(Reporter: Ric Johnson, Assigned: Joe Chou)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-21mdksmp i686; Nav)
BuildID:    2001040105

After installing the Jave jre.xpi, selecting bookmarks and/or address bar entry
cause mozilla to crash.

Reproducible: Always
Steps to Reproduce:
1. Install mozilla 2001040105 for Linux using the xpi and 'local' installer;
install all but talkback.
2. Surf to various sites after moz starts
3. Try to dld a new theme-twice(gray modern) from xthemes.org
4. goto java.sun.com so it's the 'last site' visited. (Note: browser should be
set to open the last site visited when it's started or set it as the 'home' page
and open browser to 'home')
5. Install shockwave flash by copying to 'plug-ins'
6. Install jre.xpi by surfing to local drive/dir and double-clik on file.
7. 'Quit' moz.
8. Start mozilla(usr/local/mozilla/mozilla) 
9. Manually enter a well known address -or- choose a bookmark -or- click a link
-or- click a personal toolber item.
 

Actual Results:  moz crashes

Expected Results:  to get to the selected URL address

I don't know how many of 'my' steps might be required, but those are basically
the things I did.

I tried running it from the command line(#> /usr/local/mozilla/mozilla); after
java loaded, the window opened and:

It's NOT UTF-16LE- byte 23(17)
It's NOT UTF-16BE- byte 134(86)
Document http://java.sun.com/ loaded successfully
/usr/local/mozilla/run-mozilla.sh: line 72: 18392 Segmentation fault      $prog
${1+"$@"}
It's 03:36:12 on Mon Apr  2.

I also tried entering the URL address(e.g., 208.133.27.17); moz statusbar still
said 'resolving' and crashed.


Moz appeared to work normally before the flash and java were installed.

Also,
I removed the installation and reinstalled. 
I surfed a bit - normal.
Then the plugins were installed.
First shockwave ; everything relatively normal but shockwave flash player may
not be working anymore- somethings amiss.
Then Java. I quit so it would work.  I did _not_ have the browser set to
java.sun.com.
I restarted moz. I _could_ get to other sites but if I go to java.sun.com, I get
stuck there. I cannot leave the site for another or even reload the page.

After all of that, I thought the 'old' cache might be causing pbs so I renamed
the "Cache" to "OldCache".  And tried the sites again -still no go.

I also deleted the flash player plugins from the plugin dir - still no go.

The last thing was to try from the cli again. 
:
It's NOT UTF-16LE- byte 23(17)
It's NOT UTF-16BE- byte 134(86)
Document http://java.sun.com/ loaded successfully

When I clicked on a link on the Sun Java home page:

/usr/local/mozilla/run-mozilla.sh: line 72: 20501 Segmentation fault      $prog
${1+"$@"}


I do not know if all java enabled sites cause this seg fault or just
java.sun.co. but this site :
http://www.javaappletstore.com/cool_java_applets/banners/timedatebanner.html
causes moz to go into an infinite 'resolving'.  It does not crash, though.  You
just have to kill it.

I cannot use it in this state.

RIc
===

Comment 1

17 years ago
updating component.
Assignee: asa → edburns
Status: UNCONFIRMED → NEW
Component: Browser-General → OJI
Ever confirmed: true
QA Contact: doronr → shrir

Comment 2

17 years ago
What Linux Dist and version are you using?
(Reporter)

Comment 3

17 years ago
`Linux 2.2.17-21mdksmp i686' is the Linux-Mandrake 7.2 version of MandrakeSoft's distribution; running their patched(mostly AC) Linux 2.2.17 SMP kernel on dual PIII 450's w/ 256MB SDRAM& & >1GB _free_ HD usr space in a multi-boot setup.
Pretty standard devel type setup w/ gcc-2.95.2(Very patched =>~2.95.3) glibc 2.1, i.e.,No cooker! 
I would gladly blame this on my sys (and FixIt!;) but Moz is the only program objecting at this time... :(

Have a good'un,
Ric
=== 


Comment 4

17 years ago
I can't reproduce this on my RedHat 7.0 system.  Let's see if Joe has any luck.

Joe, can you reproduce this?

Ed
Assignee: edburns → joe.chou
(Assignee)

Comment 5

17 years ago
Reporter, have you tried this on Redhat Linux? 
(Reporter)

Comment 6

17 years ago
Hey:
Nope. Don't use RH7.0 or 7.1 or LM8.0 ( or any gcc 2.96-xx compiled binaries) at all.   
If you guys have used the same steps with the same Moz version and cannot reproduce I'll vote for resolving this with "Later" just in case it should rear it's ugly head in the future.  After all it was a build from a month ago...  Or, I suppose, you can just kill it with `invalid'.

Have A Great Day!

Ric
(Assignee)

Comment 7

17 years ago
Could not reproduce it on RedHat. Mark it invalid.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 8

17 years ago
SPAM: reassigning OJI bugs to new QA, pmac. (227 bugs)
QA Contact: shrir → pmac

Comment 9

16 years ago
Verified
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.