Last Comment Bug 743813 - Fix the warnings generated by WebGL activeTexture
: Fix the warnings generated by WebGL activeTexture
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla14
Assigned To: Benoit Jacob [:bjacob] (mostly away)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-09 14:10 PDT by Benoit Jacob [:bjacob] (mostly away)
Modified: 2012-04-11 09:02 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix the warning (1.22 KB, patch)
2012-04-09 14:10 PDT, Benoit Jacob [:bjacob] (mostly away)
jgilbert: review+
Details | Diff | Splinter Review

Description Benoit Jacob [:bjacob] (mostly away) 2012-04-09 14:10:31 PDT
Created attachment 613389 [details] [diff] [review]
fix the warning

Current warnings are bogus/misleading.

+ some minor style/code enhancements.
Comment 1 Jeff Gilbert [:jgilbert] 2012-04-09 16:05:47 PDT
Comment on attachment 613389 [details] [diff] [review]
fix the warning

Review of attachment 613389 [details] [diff] [review]:
-----------------------------------------------------------------

::: content/canvas/src/WebGLContextGL.cpp
@@ +137,5 @@
> +    if (texture < LOCAL_GL_TEXTURE0 ||
> +        texture >= LOCAL_GL_TEXTURE0 + mGLMaxTextureUnits)
> +    {
> +        return ErrorInvalidEnum(
> +          "ActiveTexture: texture unit %d out of range. "

Should be 4-space not 2-space.
Comment 2 Benoit Jacob [:bjacob] (mostly away) 2012-04-10 08:53:32 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/8a59c745c563
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2012-04-10 09:24:30 PDT
fix warning causing error due to WARNINGS_AS_ERRORS:

http://hg.mozilla.org/integration/mozilla-inbound/rev/b1bed3ae0476

Note You need to log in before you can comment on or make changes to this bug.