webrtc/signaling code crashes when multiple instances are running.

RESOLVED FIXED in mozilla18

Status

()

Core
WebRTC: Signaling
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: ehugg, Assigned: ehugg)

Tracking

({crash})

Trunk
mozilla18
x86_64
Linux
crash
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC], [blocking-webrtc+] [qa-])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120310010316

Steps to reproduce:

All instances of SIPCC use the same names in the timer code - /tmp/CprTmrClient and /tmp/CprTmrServer.  This causes problems when multiple instances are running.
(Assignee)

Comment 1

5 years ago
Created attachment 613431 [details]
Fix to enable timers to work for more than instance on Linux/Mac
Attachment #613431 - Flags: feedback?(rjesup)
(Assignee)

Comment 2

5 years ago
Comment on attachment 613431 [details]
Fix to enable timers to work for more than instance on Linux/Mac

Same fix for Linux/Mac adding PID to name.
Attachment #613431 - Flags: feedback?(snandaku)
Comment on attachment 613431 [details]
Fix to enable timers to work for more than instance on Linux/Mac

Since I wrote the code, I'm more than willing to + it!  :-)
Attachment #613431 - Flags: feedback?(rjesup)
Attachment #613431 - Flags: feedback?(ethanhugg)
Attachment #613431 - Flags: feedback+

Updated

5 years ago
Assignee: nobody → ethanhugg
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 4

5 years ago
Comment on attachment 613431 [details]
Fix to enable timers to work for more than instance on Linux/Mac

Would still like to find a way to move away from this CPR code.
Attachment #613431 - Flags: feedback?(ethanhugg) → feedback+

Updated

5 years ago
QA Contact: jsmith

Updated

5 years ago
Whiteboard: [WebRTC], [blocking-webrtc+]
Linux was fixed in bug 745349 (along with a bunch of others)

darwin timers weren't hit in that bug, so this needs to be landed on that file (and try to make it match the code in the linux patch already landed)
(Assignee)

Comment 6

5 years ago
Comment on attachment 613431 [details]
Fix to enable timers to work for more than instance on Linux/Mac


This was pushed to Alder before the big rollup-review (bug 792188).

Related follow-on bug is here https://bugzilla.mozilla.org/show_bug.cgi?id=794240
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Severity: normal → critical
Keywords: crash
Target Milestone: --- → mozilla18
(Assignee)

Updated

5 years ago
Attachment #613431 - Flags: feedback?(snandaku)

Updated

5 years ago
Whiteboard: [WebRTC], [blocking-webrtc+] → [WebRTC], [blocking-webrtc+] [qa-]

Updated

5 years ago
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.