The virtual keyboard is not dismissed when double tap zooming on other articles in the page

RESOLVED WONTFIX

Status

()

Firefox for Android
General
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: AdrianT, Unassigned)

Tracking

14 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -)

Details

(Reporter)

Description

6 years ago
Fennec/14.0a1 2012-04-09
Device: Motorola Droid 2(Android 2.3)

Steps to reproduce:
1. Go to yahoo.com.
2. Change to the Desktop version.
3. After the keyboard comes up, double tap on one of the articles in view to read it.

Expected results:
Double tap should dismiss the keyboard as the user is trying to read an article and is not interested in entering any data in the text field.

Actual results:
The article is focused but the keyboard remains up. The user needs to specifically tap outside of the field to dismiss the keyboard.

Notes: 
The issue is not reproducible on the Android Browser. Double tap zoom out does not dismiss the keyboard( when the field is focused the view is zoomed on the field) but any double tap zoom in action dismisses the keyboard.
What does stock do?
Component: IME → General
QA Contact: ime → general
(Reporter)

Comment 2

6 years ago
On the Android Browser double tap zoom out does not dismiss the keyboard(when the field is focused the view is zoomed on the field so double tap zooms out) but any double tap zoom in action dismisses the keyboard.
Component: General → IME

Updated

6 years ago
Component: IME → General
For me, the stock Android browser does not dismiss the virtual keyboard when double tapping on another area on the page.
Tested on the Samsung Galaxy SII, so I can't reproduce what you are seeing with the stock browser.

Comment 4

6 years ago
looks like the cursor focus is still in the search box when double tapping.  VKB will appear as long as cursor is in textbox focus, so wondering if this is just by bad design.

HTC Sensation, Android 2.3.4, 04-23-2012 nightly.

nom'ing for triage team to discuss if this is expected behavior or not.
blocking-fennec1.0: --- → ?
(Reporter)

Comment 5

6 years ago
The behavior on the Android Browser is not really consistent when zooming out ( I am seeing the VKB being dismissed sometimes or not being dismissed other times) but when zooming in on an article I am always seeing the VKB being dismissed. Tested on Motorola Droid 2(Android 2.3) and HTC Desire (Android 2.2). Please see the video http://youtu.be/yzJclup_tZQ for the Android Browser behavior.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Updated

6 years ago
blocking-fennec1.0: ? → -
You need to log in before you can comment on or make changes to this bug.