Runfield demo game (canvas) jerky on linux

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: jhorak, Unassigned)

Tracking

11 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
This is most likely Linux specific.
From https://bugzilla.redhat.com/show_bug.cgi?id=810642 :

Reproduction steps:
http://mozillademos.org/demos/runfield/demo.html
Jump over holes.

Actual results:
On almost each jump it gets stuck for about 0.5sec, the game is not playable.

When sound is turned off it works much better.
(In reply to jhorak from comment #0)
> When sound is turned off it works much better.

It's a known problem that sound makes stuff very slow particularly on linux; over to sound folks for triaging/duping.
Component: Canvas: 2D → Video/Audio
QA Contact: canvas.2d → video.audio
(For remaining Canvas2D/linux performance issues, you may want to try gfx.canvas.azure.enabled=true in about:config, as well as the ongoing work to enable GL layers on linux and stop using x pixmaps)
(Reporter)

Comment 3

6 years ago
The performance is better with Firefox 12 (jerky is gone when playing sounds). I believe we can close it as works for me.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Thanks for the update.  The symptoms sound like bug 752141, which has a patch but hasn't landed yet.  If you see the problem return, please try a build that includes that fix.
You need to log in before you can comment on or make changes to this bug.