Closed Bug 743977 Opened 11 years ago Closed 11 years ago

turn off balrog client for staging and preproduction builds

Categories

(Release Engineering :: General, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bhearsum, Assigned: bhearsum)

References

Details

(Whiteboard: [balrog][staging][preprod])

Attachments

(2 files)

We have production builds reporting to the aus4-admin-dev balrog server. We also currently have staging and preproduction pointing at that server. Once those builds actually submit successfully, it's going to be very confusing to have staging and preproduction builds there, because we want aus4-admin-dev to mirror production data right now. We should probably turn off the balrog client for staging and preproduction for now. Individually people can turn it on and point it where they want, when necessary.
should we have separate instances for those?
Priority: -- → P3
Whiteboard: [balrog][staging][preprod]
In the long term, I think staging and preprod can report to the dev env. That is, once production is reporting to production. I guess we could run an instance on dev-master01 in the meantime.
We're now reporting production data automatically to aus4-admin-dev....patch incoming to shut off the client for staging/preprod.
Assignee: nobody → bhearsum
Attachment #618241 - Flags: review?(rail) → review+
Attachment #618241 - Flags: checked-in+
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
In production since noon PT.
We should set it to None or use config.get('balrog_api_root') workaround:


Exception in /builds/buildbot/builder-master/twistd.log:
2012-04-25 14:05:08-0700 [-] Unhandled Error
	Traceback (most recent call last):
	  File "/builds/buildbot/builder-master/sandbox/lib/python2.6/site-packages/twisted/application/app.py", line 311, in runReactorWithLogging
	    reactor.run()
	  File "/builds/buildbot/builder-master/sandbox/lib/python2.6/site-packages/twisted/internet/base.py", line 1165, in run
	    self.mainLoop()
	  File "/builds/buildbot/builder-master/sandbox/lib/python2.6/site-packages/twisted/internet/base.py", line 1174, in mainLoop
	    self.runUntilCurrent()
	  File "/builds/buildbot/builder-master/sandbox/lib/python2.6/site-packages/twisted/internet/base.py", line 796, in runUntilCurrent
	    call.func(*call.args, **call.kw)
	--- <exception caught here> ---
	  File "/builds/buildbot/builder-master/sandbox/lib/python2.6/site-packages/buildbot-0.8.2_hg_a2045101fe7a_production_0.8-py2.6.egg/buildbot/master.py", line 604, in loadTheConfigFile
	    d = self.loadConfig(f)
	  File "/builds/buildbot/builder-master/sandbox/lib/python2.6/site-packages/buildbot-0.8.2_hg_a2045101fe7a_production_0.8-py2.6.egg/buildbot/master.py", line 628, in loadConfig
	    exec f in localDict
	  File "/builds/buildbot/builder-master/master.cfg", line 72, in <module>
	    getattr(passwords, 'secrets', None))
	  File "/builds/buildbot/buildbotcustom/buildbotcustom/misc.py", line 1306, in generateBranchObjects
	    balrog_api_root=config['balrog_api_root'],
	exceptions.KeyError: 'balrog_api_root'
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 618635 [details] [diff] [review]
fallback when balrog_api_root isn't set

You can use config.get('balrog_api_root') (without specifying None explicitly) if you want.
Attachment #618635 - Flags: review?(rail) → review+
Attachment #618635 - Flags: checked-in+
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Landed to production today
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.