Make tap-targets for social links more obvious

VERIFIED FIXED in M3

Status

Pancake
Front-end
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: dria, Assigned: gordonb)

Tracking

unspecified
x86
Mac OS X

Details

(Whiteboard: alpha-block-nom)

Right now I have absolutely no idea what parts of the social links (ie: Twitter things) are actually hyperlinked, and there is no UI response at all when I tap things (no highlight of the tapped area and no throbber or loading indicator).

This makes it incredibly difficult to know if a tap has worked.  Pancake needs some sort of UI response for that as well as making it clear which parts are tappable (if not the whole shared item block).
So it turns out that the whole shared block is tappable, but the UI doesn't respond at all until the page starts loading.  This can often take a while and is confusing.
Whiteboard: 737023 → alpha-block-nom

Updated

6 years ago
Assignee: nobody → sfoster
Target Milestone: --- → M3
See my questions in #734239. Is the current behavior what we want? 
Meanwhile maybe we can use a down or indeterminate state for the click area to give some immediate feedback to the user.

Updated

6 years ago
Duplicate of this bug: 734239

Comment 5

6 years ago
I believe Gordon changed the behavior here after it initially landed to only let you click on the icon and title.  I don't think this behavior is what we want.  I keep clicking on the largest area of most (the description) and it doesn't open.  We should go back to clicking on a larger area.
(Assignee)

Updated

6 years ago
Assignee: sfoster → gbrander
(Assignee)

Comment 6

6 years ago
Fixed in https://bitbucket.org/mozillapancake/pancake/changeset/60dded5b8546. Wrapped the entire post content in the .link trigger, allowing any part of the post to be clicked.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Verified fixed based on comment 6.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.