Last Comment Bug 744052 - Restructure HashTable::checkOverflow for easier reading
: Restructure HashTable::checkOverflow for easier reading
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: 14 Branch
: All All
: -- normal (vote)
: mozilla14
Assigned To: Terrence Cole [:terrence]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 09:51 PDT by Terrence Cole [:terrence]
Modified: 2012-04-11 09:04 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v0 (1.73 KB, patch)
2012-04-10 09:51 PDT, Terrence Cole [:terrence]
luke: review+
Details | Diff | Splinter Review

Description Terrence Cole [:terrence] 2012-04-10 09:51:33 PDT
Created attachment 613649 [details] [diff] [review]
v0

In which :terrence reads what he wrote two weeks ago...

When I added this function, I just copied the existing logical structure.  It makes more sense here to check overflowed and return early, since we can do this now.
Comment 1 Luke Wagner [:luke] 2012-04-10 10:00:58 PDT
Comment on attachment 613649 [details] [diff] [review]
v0

Much nicer
Comment 2 Terrence Cole [:terrence] 2012-04-10 10:12:31 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/38f159e04083
Comment 3 Matt Brubeck (:mbrubeck) 2012-04-11 09:04:49 PDT
https://hg.mozilla.org/mozilla-central/rev/38f159e04083

Note You need to log in before you can comment on or make changes to this bug.