Closed Bug 744270 Opened 9 years ago Closed 8 years ago

GC: do not store post-barriered gcthings in hash tables

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 776583

People

(Reporter: terrence, Assigned: terrence)

References

Details

As with Vectors, this memory moves outside the control of the GC.  In these cases, we need to preserve pre barriers and facilitate post barriers.
Depends on: 744579
Depends on: 744609
Depends on: 744880
Depends on: 745322
Depends on: 752604
Depends on: 753931
Depends on: 763636
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 776583
You need to log in before you can comment on or make changes to this bug.