Filter Actions: Leave Message On Server, Download Message From Server

NEW
Unassigned

Status

enhancement
P5
normal
19 years ago
5 years ago

People

(Reporter: timeless, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patchlove][leave on server issue remaining])

Attachments

(1 attachment)

Reporter

Description

19 years ago
Gregor Rosenauer 2001-04-02 13:07 in bug 45609 wrote:
Please also include a "Leave message on server"-action, sothat I can leave e.g. 
my mailing-list-mails on the server (and read it over the web) and only get 
personal mail to my computer.

Can we create two new actions, (1)leave message on server, and (2)remove 
message from server.  In general, only one of these two actions will make sense 
per server.  ie if I configure a mail server to not leave messages on server 
then (1) would make sense and (2) would be meaningless, but if I configure a 
mail server to leave messages on server then (1) would be meaningless and (2) 
would be useful.

Updated

19 years ago
QA Contact: esther → laurel
Summary: Filter Actions: Leave Message On Server, Download Message From Server → RFE: Filter Actions: Leave Message On Server, Download Message From Server

Comment 1

18 years ago
adding helpwanted keyword, setting priority to p5 (for future enhancement)
Status: NEW → ASSIGNED
Keywords: helpwanted
Priority: -- → P5

Comment 2

18 years ago
I totally agree. 
I need the "Leave message on server" function!!! I have to use MS Outlook, for
my mail untill it's fixed.
Why? Me and my father have different email-adresses on the same ISP-account, the
result is that i'm getting my fathers mail on my computer if i check with
mozilla since i can't leave it on the server like in outlook.
Does this comment give it a higher priority ;-)

Updated

18 years ago
Keywords: mail3

Comment 3

18 years ago
Same here.  I have to use Outlook express because my wife and I share the same
account, but with different email addresses.  I need to leave her mail on the
server, and she needs to leave my mail there.  I don't know how difficult this
will be to implement in Mozilla but it will allow me to use my Linux properly
for mail, and also dump Outlook from 2 machines here and another 4 at work.
Maybe someone can give a higher priority to this enhancement ?

Many people really needs do some actions with mail server (ex. I really need "Do
not download some messages from server" and maybe "Delete messages from server"
or "Leave messages on server")

Where are difficulties, if nobody can implement this action in mozilla-mail ?

Comment 5

17 years ago
*** Bug 165437 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
*** Bug 117037 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
*** Bug 194087 has been marked as a duplicate of this bug. ***
Why was this bug split off from bug 45609? It's essentially a dup, the problem 
being the application of (some) filters based on headers before downloading the 
whole email. To remove the distraction, I'd suggest someone move the keywords 
and mark this bug as a dup, and that voters move their votes to 45609 (where 
more technical comments helpful to a fix have been made). If not how about 
marking a dependency so that the connection between the two is clear from both? 

Comment 9

17 years ago
A perfectly good idea.
Duped it is.
Remember to vote for bug 45609 !

*** This bug has been marked as a duplicate of 45609 ***
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Reporter

Comment 10

17 years ago
It was split off because they're entirely unrelated.

One asks for the ability to do actions before downloading.

Message Filters
[ Filter Log ]            [ timeless@myrealbox.... |v] Filters for:

Enabled filters are run automatically in the order shown below.
+------------------------------------------------------------v---------+
| Filter Name                                                | Enabled | New...
+------------------------------------------------------------+---------+ Edit...
| Large Mail Restriction               <- bug 45609 v        |    x    | Delete
|{Items above this line will be run before downloading mail }|{-------}|
| Personal Correspondence                                    |    x    |
| Junk Mail Analysis                                         |    x    | Move Up
| Default                                                    |    x    |MoveDown
+------------------------------------------------------------^---------+
Manually run selected filter(s) on folder: [ Inbox |v]                   Run Now
the other asks for new actions.

Filter Rules
Filter Name: [ Default             ]   <- bug 66771 - sort of
( ) Match all of the following (*) Match any of the following
+------------------------------------+
| [ Size ] [ is greater than ] [ 0  ]| <- bug 19402
+------------------------------------+
[ More ] [ Fewer ]

Perform these actions:
+----------------------------------------------------------------------v-+
|[x] Remove Message from Server        <- this bug (Default POP Value) |^|
|[x] Download Message Body             <- this bug (Default POP Value) | |
|/x//Download/Attachments/             <- this bug (Disabled for POP ) | |
|[ ] Move to folder:     [ timeless@myrealbox.... |v] [ New Folder... ]|x|
|[ ] Label this message: [                        |v]                  | |
|[ ] Change priority to: [ highest                |v]                  | |
|[ ] Mark message as read                                              | |
|[ ] Flag the message                                                  | |
|[ ] Delete the message                                                | |
|[ ] Ignore thread                                                     | |
|[ ] Watch thread                                                      |v|
+----------------------------------------------------------------------^-+
                                            [   OK   ] [ Cancel ] [ Help ]
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 11

16 years ago
*** Bug 207944 has been marked as a duplicate of this bug. ***
*** Bug 208428 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
*** Bug 217467 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
same as S. Malling.  I'm using 3 email account from the same isp that go
in the same inbox.  So i dont want to download email sent to my spouce neither
to my son...

Comment 15

16 years ago
this adds a filter action to delete a message from pop3 server, if messages are
left on server by default. It cleans up the whole handling of the uidl info,
and gets rid of the hacky c interfaces.

Adding a filter action to leave on server is a bit tricky since we'd need to be
leaving messages on the server and then delete all the ones that filters didn't
mark as leave on server.

Updated

16 years ago
Attachment #135446 - Flags: superreview?(mscott)

Updated

16 years ago
Attachment #135446 - Flags: superreview?(mscott) → superreview+

Comment 16

16 years ago
Comment on attachment 135446 [details] [diff] [review]
add filter action for pop3 delete from server

> RCS file: /cvsroot/mozilla/mailnews/base/resources/locale/en-US/messenger.properties,v
> +filterFolderTruncateFailed=There was an error truncating the Inbox after filtering a message to folder '%S'. You may need to shutdown Mozilla and delete INBOX.msf.

This should use brandShortName. It's a pity we don't automate the recovery that
this message instructs the user to do.

> RCS file: /cvsroot/mozilla/mailnews/base/search/resources/locale/en-US/FilterEditor.dtd,v
> +<!ENTITY deleteFromServer.label "Delete from Pop3 server">

That should probably be 'POP3 server' or 'POP server' for consistency with
other message text. We also usually include a localization note about not
translating the 'POP'.

Comment 17

16 years ago
Can anyone explain why you need a "keep on server" filter action if you have the
delete from server action? It seems to me that you can do what you want with a
"delete from server" filter action and make the default behaviour be leave on
server, especially for this multiple account issue. As I said before, adding a
"keep on server" action would mean that all our pop3 downloads would have to be
leave on server followed by deletes from server, which would be more complicated
than just deleting each message after retrieving it. It's not too hard, but I
just want to make sure people really have a need for it.

Status: REOPENED → ASSIGNED

Comment 18

16 years ago
>Can anyone explain why you need a "keep on server"... 
Yes... "we" need the mail to be left on the server, for a different computer to
then retrieve and then delete.

>...that all our pop3 downloads would have to be leave on server followed by
deletes from server...
No, that would simply mean that mozilla or thunderbird would not send the DELETE
command for the specific email.

I was looking at the RFC for pop3 at http://www.faqs.org/rfcs/rfc1939.html
and it seems like, if you alreade have got the message headers and know wich
mail you want to do what on you could just remove the DELE line or inset NOOP if
that's required   ...well at least thats my impression.

10. Example POP3 Session (from rfc1939)

      S: <wait for connection on TCP port 110>
      C: <open connection>
      S:    +OK POP3 server ready <1896.697170952@dbc.mtview.ca.us>
      C:    APOP mrose c4c9334bac560ecc979e58001b3e22fb
      S:    +OK mrose's maildrop has 2 messages (320 octets)
      C:    STAT
      S:    +OK 2 320
      C:    LIST
      S:    +OK 2 messages (320 octets)
      S:    1 120
      S:    2 200
      S:    .
      C:    RETR 1
      S:    +OK 120 octets
      S:    <the POP3 server sends message 1>
      S:    .
      C:    DELE 1
      S:    +OK message 1 deleted
      C:    RETR 2
      S:    +OK 200 octets
      S:    <the POP3 server sends message 2>
      S:    .
      C:    DELE 2
      S:    +OK message 2 deleted
      C:    QUIT
      S:    +OK dewey POP3 server signing off (maildrop empty)
      C:  <close connection>
      S:  <wait for next connection>

Thank's for picking this bug up!

Comment 19

16 years ago
>>Can anyone explain why you need a "keep on server"... 
>Yes... "we" need the mail to be left on the server, for a different computer to
>then retrieve and then delete.
David was saying that exactly this behaviour can be achieved with his
implementation:
In your Mozilla, set 'keep messages on server'. Then create a filter that all
emails addressed to YOU wil be 'deleted from server'.

Your father/son will do the same: he will make a filter to DELETE emails
addressed to HIM.

The only problem is, that both of you will download ALL email, and then the
filter will delete the appropriate email on the server. But you have to delete
email not addressed to you locally. So, in addition to the mentioned filter,
another one has to be created: move all messages NOT addressed to ME to Trash.
This isn't good for dialup users, but kinda works.

David, do you now see the difference? This could be fixed together with bug 45609.


Comment 20

16 years ago
you may not need a new filter - you could just add a "delete from server" action
to your existing filters, if you have existing filters.

Comment 21

16 years ago
(In reply to comment #19)
> >>Can anyone explain why you need a "keep on server"... 
> >Yes... "we" need the mail to be left on the server, for a different computer to
> >then retrieve and then delete.
> David was saying that exactly this behaviour can be achieved with his
> implementation:
> In your Mozilla, set 'keep messages on server'. Then create a filter that all
> emails addressed to YOU wil be 'deleted from server'.
> 
> Your father/son will do the same: he will make a filter to DELETE emails
> addressed to HIM.
> 
> The only problem is, that both of you will download ALL email, and then the
> filter will delete the appropriate email on the server. But you have to delete
> email not addressed to you locally. So, in addition to the mentioned filter,
> another one has to be created: move all messages NOT addressed to ME to Trash.
> This isn't good for dialup users, but kinda works.
> 
> David, do you now see the difference? This could be fixed together with bug 45609.
> 
> 
> 

Seems ok but this settings dont work at all because the emails arent deleted
from server.  I choose delete when moved from inbox OR delete aftar x days and
both dont work
*** Bug 238270 has been marked as a duplicate of this bug. ***

Comment 23

15 years ago
*** Bug 238805 has been marked as a duplicate of this bug. ***
Product: MailNews → Core

Comment 24

14 years ago
I think this bug was fixed with bug 185184.

Comment 25

14 years ago
*** Bug 259078 has been marked as a duplicate of this bug. ***

Comment 26

14 years ago
For some insight into why users might need the "leave on server" feature, see
this MozillaZine forum post:

http://forums.mozillazine.org/viewtopic.php?t=271590

Quite frankly, even if the "delete from server" feature could handle the issue,
from the end-user perspective a single "leave on server" filter option is a lot
easier to figure out than finding the global "leave on server" option AND
setting an additional "delete from server" filter for your own alias address;
plus, it "just works" with the default Thunderbird settings (i.e. deleting mail
off the server by default).  Also, a lot of Thunderbird users are coming from
Outlook Express, and OE has this option, so the transition for lots of Windows
users would be easier.

Comment 27

14 years ago
Actually, thinking it over, the suggestion to turn on the "leave messages on
server" account setting and make a "delete from server" filter for the current
user would NOT work for the majority of settings where people need a "do not
download message" filter option, because "do not download message" is not the
same thing as "leave message on server", in this case.

That is, usually people who want this filter option need it so that they DON'T
recieve any mail into an e-mail alias where it doesn't belong.  If they simply
checked the "leave messages on server" option in the Account Settings, and made
a filter that deleted any e-mail addressed to that alias from the server, they
would still be recieving the unwanted mail from the other alias into that inbox.
 Therefore, in a situation where someone has two e-mail aliases assigned to one
account, a "Do not download message from server" filter option is the only
solution.  Perhaps this particular filter action (clarified as "Do not download
message from server" instead of "Leave message on server") needs a new bug number.

Comment 28

14 years ago
*** Bug 310949 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Duplicate of this bug: 320635
Whiteboard: [leave on server issue remaining]

Comment 30

12 years ago
(In reply to comment #17)
> Can anyone explain why you need a "keep on server" filter action if you have
> the
> delete from server action? 

I can. I have a mail account with an infinite number of aliases (i.e. anything@galenx.org.uk (munged) reaches me). My other half used to use the same server with the same log-in. To make sure that she got her mail I had to have a "leave mail to her personal address on server" filter, thus leaving everything else for me to download in one pass. I could do this with OE. If you only have the "delete from server option" you cannot do this. Even if it were possible to set up a "delete from server if NOT her personal address" it would still not work, as when I downloaded the messages I would also download her messages, which might be private. 

I know of several other people with the same problem, and a "leave on server" filter is the only way round it.

Updated

11 years ago
QA Contact: laurel → filters
Product: Core → MailNews Core
Summary: RFE: Filter Actions: Leave Message On Server, Download Message From Server → Filter Actions: Leave Message On Server, Download Message From Server

Updated

8 years ago
Blocks: 66425

Comment 31

8 years ago
David :Bienvenu, are you still working on it, or will you de-assign this?

Comment 32

8 years ago
I'm happy to let someone else tackle this, sure.
Assignee: dbienvenu → nobody

Updated

8 years ago
Status: ASSIGNED → NEW

Updated

5 years ago
Keywords: helpwanted
Whiteboard: [leave on server issue remaining] → [patchlove][leave on server issue remaining]
You need to log in before you can comment on or make changes to this bug.