Telemetry for slow setTimeout

RESOLVED DUPLICATE of bug 744470

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 744470
6 years ago
6 years ago

People

(Reporter: Yoric, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

As discussed on IRC, it would be nice to have some Telemetry information on window.setTimeout calls that take too long.

I would say:
- we probably want this only for chrome content-issued setTimeout;
- we probably want to attach the file + line info to the histogram, much as we attach some source code to Telemetry of slow SQL queries;
- how long is "too long"? setTimeouts that are triggered more than 300ms after the expected date, for instance?
> - we probably want this only for chrome content-issued setTimeout;

I'm not sure what that means.

> we probably want to attach the file + line info to the histogram

We can try, but I will bet that in most cases we don't have this....

Comment 2

6 years ago
i'm going to drive this in bug 744470
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 744470
You need to log in before you can comment on or make changes to this bug.