All users were logged out of Bugzilla on October 13th, 2018

Text in Error Console is not partially selectable

RESOLVED DUPLICATE of bug 584346

Status

RESOLVED DUPLICATE of bug 584346
7 years ago
2 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

18 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120313130328

Steps to reproduce:

I visited a page which produced an error


Actual results:

The error was displayed in the error console (as it should). When I attempted to select the error text for copy-pasting it into google, nothing happened.



Expected results:

I should be able to select the error message.

Googling for an error message in a web page is a common enough use-case that this should be supported.

In the past, similar bugs have been reported about other dialog boxes or message windows in Firefox. Why not take the systematic approach, and make any text displayed selectable _generally_. I.e. is there any good reason to make some text _not_ selectable? I mean, any reason other than "Internet Explorer doesn't even have the concept of selecting text". If I wanted Internet Explorer, I would use Internet Explorer, thank you. I use Firefox because I expect something better. Sorry for that last comment, but this bug really feels like somebody wanted to emulate windows' crappiness :-)

Comment 1

6 years ago
Alain, still see this?
Flags: needinfo?(mozilla)
Whiteboard: [closeme 2013-05-01]
(Reporter)

Comment 2

6 years ago
Unfortunately yes (in Firefox 18.0.2)

It's actually quite easy to check, because this very bug-reporting page has bugs in the CSS, prompting such messages as "Expected declaration but found '*' ..." (re-typed, due to this bug).

So, checking this bug was just a matter of going to Tools->Developer->ErrorConsole, an attempting to select some text...

It took me more time to type this answer, than the actual check itself :-)
Flags: needinfo?(mozilla)
(Reporter)

Comment 3

6 years ago
Bug is present also in Thunderbird's about box (and possibly many other places too), but oddly enough not in Firefox's about box...

Why isn't text of dialogs generally copy-pastable? It's obvious that error messages are useful to copypaste (when googling for a solution), and so are version numbers (such as, when responding to questions in bug reports such as this one :-) )

Updated

6 years ago
Component: Untriaged → Error Console
Product: Firefox → Toolkit
Whiteboard: [closeme 2013-05-01]
Version: 11 Branch → 18 Branch

Comment 4

5 years ago
(In reply to Alain Knaff from comment #3)
> Bug is present also in Thunderbird's about box (and possibly many other
> places too), but oddly enough not in Firefox's about box...

works for me on windows.

FWIW, per bugzilla you are the only person reporting this issue, so I suspect something in your profile.

does this and comment 0 reproduce in a new profile?
does anything appear in the error console? :)
Flags: needinfo?(mozilla)
(Reporter)

Comment 5

5 years ago
The about box bug is still present on Thunderbird 17.0.2

The firefox error console issue still happens in Firefox 18.0.2, even in a new profile .

I do not quite understand the purpose of the question "does anything appear in the error console?"
Flags: needinfo?(mozilla)

Comment 6

5 years ago
(In reply to Alain Knaff from comment #5)
> The about box bug is still present on Thunderbird 17.0.2

with a new profile? 
ref https://support.mozillamessaging.com/en-US/kb/using-multiple-profiles

> The firefox error console issue still happens in Firefox 18.0.2, even in a
> new profile .
> 
> I do not quite understand the purpose of the question "does anything appear
> in the error console?"

(do we have a language barrier?) when you attempt to select or attempt to copy, does anything appear in error console?
(Reporter)

Comment 7

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #6)
> (In reply to Alain Knaff from comment #5)
> > The about box bug is still present on Thunderbird 17.0.2
> 
> with a new profile? 
> ref https://support.mozillamessaging.com/en-US/kb/using-multiple-profiles

Yes, with a new profile. Is it supposed to work now? Has any change been committed to fix this? If yes, in what version? Or what other steps have been taken to make this work?

> 
> > The firefox error console issue still happens in Firefox 18.0.2, even in a
> > new profile .
> > 
> > I do not quite understand the purpose of the question "does anything appear
> > in the error console?"
> 
> (do we have a language barrier?) when you attempt to select or attempt to
> copy, does anything appear in error console?

No additional error appears when attempting to select those that are already there.


I see that you are reacting to bugs reported over wide areas of Firefox and Thunderbird. Are you actually knowledgeable enough in all those areas to really help?

Comment 8

5 years ago
(In reply to Alain Knaff from comment #7)
> (In reply to Wayne Mery (:wsmwk) from comment #6)
> > (In reply to Alain Knaff from comment #5)
> > > The about box bug is still present on Thunderbird 17.0.2
> > 
> > with a new profile? 
> > ref https://support.mozillamessaging.com/en-US/kb/using-multiple-profiles
> 
> Yes, with a new profile. Is it supposed to work now? Has any change been
> committed to fix this? If yes, in what version? Or what other steps have
> been taken to make this work?

I see nothing so far that makes me believe the problem is in mozilla code. In part because, as I said, you are the only person reporting this problem in bugzilla. 

But I defer to someone with more linux experience than me
> > > The firefox error console issue still happens in Firefox 18.0.2, even in a
> > > new profile .
> > > 
> > > I do not quite understand the purpose of the question "does anything appear
> > > in the error console?"
> > 
> > (do we have a language barrier?) when you attempt to select or attempt to
> > copy, does anything appear in error console?
> 
> No additional error appears when attempting to select those that are already
> there.
> 
> 
> I see that you are reacting to bugs reported over wide areas of Firefox and
> Thunderbird. Are you actually knowledgeable enough in all those areas to
> really help?

judge for yourself https://bugzilla.mozilla.org/buglist.cgi?f1=OP&emailreporter1=1&o3=anywordssubstr&list_id=6870338&classification=Client%20Software&classification=Components&emailtype1=substring&o2=anywordssubstr&f4=CP&query_format=advanced&j1=OR&f3=keywords&f2=short_desc&email1=vseerror%40lehigh.edu
Flags: needinfo?(matspal)
I'm not very familiar with the Error Console design, but I think the behavior
is intentional.  The way to copy an error message is to click on an error in
the list and then CTRL+C (or click Copy in the context menu) and then paste it
where you want it.  I don't think selecting text within an error message is
supported in this window.  I agree it's a bit confusing unless you recognise
this is a "list of items" where such behavior is normal (compare with the list
of cookies in Preferences/Privacy or other similar lists in UI).

Fwiw, the Error Console has been replaced with Browser Console in newer
versions, where the list is more recognisable as a list since (most)
items are now single line, so it might be less confusing.
Flags: needinfo?(matspal)

Comment 10

3 years ago
oh yeah, this is by design. you can't select specific text/subset of an item.
one selects the entire item, which works (or should)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Summary: Error messages in Error Console are not selectable → Error text in Error Console is not selectable
(Reporter)

Comment 11

3 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #10)
> oh yeah, this is by design.

Ok, so that would have made it a design bug rather than an implementation bug. But still a bug.

In any case, retrying this now on the *browser* console in Firefox, it now works (43.0.4) => good.

However the issue still exists in *Thunderbird*'s error console (38.5.1).

> you can't select specific text/subset of an item.

The question is "... but why?"

It's funny to go over the comment history of this bug: you (Wayne) are the same guy who:
1. First implied the problem might be fixed (comment #1).
2. Then implies that it really is my profile (comment #4).
3. Finally admits that the problem does indeed exist, but is intentional (comment #10)

... all without excuses and acknowledgments that you had been wrong earlier. Maybe you should indeed defer to somebody with more experience than you? :-)

> one selects the entire item, which works (or should)

There is indeed a right menu item to select an entire item, which does work. But the point still remains: "why?". As it is now, it is neither possible (in Thunderbird) to select part of an entry, nor multiple entries, and for what benefit?

Is there an easy way to move this bug over to Thunderbird's bugzilla?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 12

3 years ago
I reserve the right to be bold enough to be wrong, and appreciate when someone offers a correction. :)
Yes, you are correct.  But isn't this the same thing as bug 584346?

One path forward for Thunderbird is aluded to by mats in comment 4.  If Browser Console were made available then that solves *many* limitations of the current Error Console (accessibility for example). I've been thinking about file a bug report to do just that.

And in speaking with mossop, Error Console lacks a module owner plus so it is unlikely to get a paid mozilla person in that position, so double unlikely bugs in this componenent will be fixed any time foreseeable future.
Flags: needinfo?(mozilla)
Summary: Error text in Error Console is not selectable → Text in Error Console is not partially selectable
(Reporter)

Comment 13

3 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #12)
> I reserve the right to be bold enough to be wrong, and appreciate when
> someone offers a correction. :)
> Yes, you are correct.  But isn't this the same thing as bug 584346?

Oops, looks like I already had reported it... But #584346 seems to be about thunderbird (where the problem still exists), and this one here is about firefox (where it has been fixed).

Hmm, I just noticed that here in bugzilla, it seems to really hard to tell about which application the bug actually was... I figured from my description "I visited a *page* which produced an error" that this one here (#744335) was indeed about Firefox (you don't visit pages in Thunderbird), whereas the other one is indeed about thunderbird (mentions the version number of Thunderbird in description). So you can indeed close this one (#744335), but keep the other one (#584346) open.

Sorry, when I made comment #11, I had completely forgotten that I already had filed it in Thunderbird...

> 
> One path forward for Thunderbird is aluded to by mats in comment 4.  If
> Browser Console were made available then that solves *many* limitations of
> the current Error Console (accessibility for example). I've been thinking
> about file a bug report to do just that.

Indeed.
 
> And in speaking with mossop, Error Console lacks a module owner plus so it
> is unlikely to get a paid mozilla person in that position, so double
> unlikely bugs in this componenent will be fixed any time foreseeable future.

Wouldn't it be possible to just redo on Thunderbird's codebase whatever has been done in Firefox' codebase (where the problem obviously has been fixed sometimes between June 2013 and now...)
Flags: needinfo?(mozilla)

Comment 14

3 years ago
(In reply to Alain Knaff from comment #13)
> (In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment
> #12)
> > I reserve the right to be bold enough to be wrong, and appreciate when
> > someone offers a correction. :)
> > Yes, you are correct.  But isn't this the same thing as bug 584346?
> 
> Oops, looks like I already had reported it... But #584346 seems to be about
> thunderbird (where the problem still exists), and this one here is about
> firefox (where it has been fixed).

I believe you are mistaken.  This works in Firefox's newishBrowser Console, which is brought up by ctrl+shift+J. But it is still broken in Error Console, which is a different console - which is this bug.

> Hmm, I just noticed that here in bugzilla, it seems to really hard to tell
> about which application the bug actually was... I figured from my
> description "I visited a *page* which produced an error" that this one here
> (#744335) was indeed about Firefox (you don't visit pages in Thunderbird),
> whereas the other one is indeed about thunderbird (mentions the version
> number of Thunderbird in description). So you can indeed close this one
> (#744335), but keep the other one (#584346) open.

Thunderbird shares with Firefox in *many* areas which are in the Toolkit product category https://bugzilla.mozilla.org/describecomponents.cgi?product=Toolkit  

> Sorry, when I made comment #11, I had completely forgotten that I already
> had filed it in Thunderbird...

no problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 584346
(Reporter)

Comment 15

3 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #14)
[...]
> I believe you are mistaken.  This works in Firefox's newishBrowser Console,
> which is brought up by ctrl+shift+J. But it is still broken in Error
> Console, which is a different console - which is this bug.

Strange. Maybe I'm looking in the wrong place, but I couldn't find an ErrorConsole anywhere in the current Firefox' menus. The only thing I found is the new Browser Console, which seems to do more or less the same job as the error console, minus the bug.

But it could of course be that the old Error Console is still somewhere, and I just looked in the wrong place.


[...]
> Thunderbird shares with Firefox in *many* areas which are in the Toolkit
> product category
> https://bugzilla.mozilla.org/describecomponents.cgi?product=Toolkit  

Unfortunately, in some cases, bugs may be fixed in Firefox, but still present in Thunderbird, which may lead to confusion...
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.