Status

()

Core
Networking: Cache
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: Jan Carpenter, Assigned: gordon)

Tracking

({crash, topcrash})

Trunk
x86
Windows NT
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cache], crash signature)

(Reporter)

Description

17 years ago
This is a topcrasher 

Here is a stack trace:
         NKCACHE.DLL + 0x52ab (0x607952ab)  
         NKCACHE.DLL + 0x3d54 (0x60793d54)  
         NKCACHE.DLL + 0x3c10 (0x60793c10)  
         NKCACHE.DLL + 0x39af (0x607939af)  
         NKCACHE.DLL + 0x3b8e (0x60793b8e)  
         NKCACHE.DLL + 0x4422 (0x60794422)  
         NECKO.DLL + 0x2ed3a (0x6074ed3a)  
         NECKO.DLL + 0x2f8bf (0x6074f8bf)  
         NECKO.DLL + 0x2e429 (0x6074e429)  
         NECKO.DLL + 0x8624 (0x60728624)  
         NECKO.DLL + 0x8530 (0x60728530)  
         GKCONTENT.DLL + 0x458ee (0x015c58ee)  
         GKCONTENT.DLL + 0x4ed77 (0x015ced77)  
         GKCONTENT.DLL + 0x4f259 (0x015cf259)  
         GKCONTENT.DLL + 0x43b0b (0x015c3b0b)  
         GKCONTENT.DLL + 0x43ee6 (0x015c3ee6)  
         GKCONTENT.DLL + 0x42338 (0x015c2338)  
         GKPARSER.DLL + 0xbc61 (0x603dbc61)  
         GKPARSER.DLL + 0xbd36 (0x603dbd36)  
         GKPARSER.DLL + 0xa22a (0x603da22a)  
         GKPARSER.DLL + 0x9412 (0x603d9412)  
         GKPARSER.DLL + 0x8ecc (0x603d8ecc)  
         GKPARSER.DLL + 0x167bd (0x603e67bd)  
         GKPARSER.DLL + 0x16658 (0x603e6658)  
         GKPARSER.DLL + 0x169dd (0x603e69dd)  
         URILDR.DLL + 0x5108 (0x60a25108)  
         NECKO.DLL + 0x360b6 (0x607560b6)  
         NECKO.DLL + 0x34d13 (0x60754d13)  
         NECKO.DLL + 0xddf6 (0x6072ddf6)  
         NECKO.DLL + 0xd849 (0x6072d849)  
         XPCOM.DLL + 0x1189 (0x60dc1189)  
         XPCOM.DLL + 0x15ad (0x60dc15ad)  
         XPCOM.DLL + 0x2a52e (0x60dea52e)  
         KERNEL32.DLL + 0x245af (0xbff945af)  
         0x00688b5e  


User comments that might help repro this crash; most have to do with crashing 
on exit:

(28525965) logged out, then closed window

(28472718) quitting after making bm changes 

(28433760) closed browser window after opening the news
                         page from the frame of www.storagereview.com
                         and the page wouldn't render. 

(28389804) windows 95 support pages, attempting a
                         download 

(28387308) Mozilla took a long time to resolve the host
                         boards.straightdope.com. I had three windows
                         open all looking for this same address. The crash
                         occured when I closed all windows. 

(28380491) didn't do anything, just crashed while it was in the
                         background 

(28354793) crash on quit

(28265136) loaded the weather report for zip code 60637 then
                         reloaded it 

(28258170) MOZILLA ?I?y?[?W?a???????B ???W???[?? :
                         NKCACHE.DLL?A?A?h???X : 016f:607952ab
                         Registers: EAX=01f2b8a0 CS=016f
                         EIP=607952ab EFLGS=00010202 EBX=00200064
                         SS=0177 ESP=0068ee28 EBP=0068ee34
                         ECX=01f28460 DS=0177 ESI=01f2b8a0 FS=3af7
                         EDX=01f2b8c9 ES=0177
(Reporter)

Comment 1

17 years ago
adding crash & topcrash keywords
Keywords: crash, topcrash
(Assignee)

Updated

17 years ago
Whiteboard: [cache]

Comment 2

17 years ago
I bet this NKCACHE.DLL crash relates to one or more of these other
stack signatures... found in the M0.8.1 data.

0x0000006d be75be14  Opened Mozilla - as soon as the screen was visible I closed 
it with the X button. ----> BOOM tried it several times and it crashes every 
time Windows NT  4.0 build 1381

DocumentViewerImpl::CreateStyleSet fa59e01d 
d:\builds\0.8.1\mozilla\content\base\src\nsDocumentViewer.cpp printed this page 
- I clicked on the close window button.and mozilla crashed Windows NT  4.0 build 
1381

libc.so.6 + 0x96584 (0x402dc584) 922ffb96  I was attempting to close one open 
browser window and the whole application shutdown. Linux 2.2.17-21mdk

nsCacheManager::LimitDiskCacheSize a561cc63 
d:\builds\0.8.1\mozilla\netwerk\cache\mgr\nsCacheManager.cpp  and win2k said 
"creating error log" Windows NT  5.0 build 2195

nsHTTPChannel::CacheAbort 18a9e320 
d:\builds\0.8.1\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp I started 
browser and modified preferences and then I closed browser by pressing X in the 
top right corner. Windows NT  5.0 build 2195

nsHTTPChannel::GetSecurityInfo 7bdcb04a 
d:\builds\0.8.1\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp  did not 
finish downloading it. Windows 98  4.10 build 67766446

nsHTTPChannel::GetSecurityInfo 7bdcb04a 
d:\builds\0.8.1\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp  though it 
is really a tempatation to do it. I Windows 98  4.10 build 67766446

nsHTTPChannel::GetSecurityInfo a1445c3e 
d:\builds\0.8.1\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp Had many 
windows opened and one had some kind of strange plugin.One window showed like a 
text view of an .exe file. It begin with MZ i think.Mozilla crashed when i 
closed the last window opened. Windows 98  4.10 build 67766446

nsHTTPChannel::GetSecurityInfo d5ddd3ac 
d:\builds\0.8.1\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp close 
browser --> crash Windows NT  5.0 build 2195
Summary: crash [@ NKCACHE.DLL] → crash [@NKCACHE.DLL]
Whiteboard: [cache]

Updated

17 years ago
Whiteboard: [cache]
(Assignee)

Comment 3

17 years ago
This bug isn't related to the 0.8.1 stack traces because it's completely
different code.  However, I believe it is very likely a duplicate of several
other bugs we recently fixed with the landing of the DISKCACHE1_BRANCH.

I'm going to mark this FIXED.  If we still see a topcrasher in the NKCACHE.DLL,
just make a new bug.

Thanks.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Crash Signature: [@NKCACHE.DLL]
You need to log in before you can comment on or make changes to this bug.