Loading a page will sometimes show checkerboard background

VERIFIED WORKSFORME

Status

()

Firefox for Android
General
VERIFIED WORKSFORME
6 years ago
2 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -, fennec15+)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 614104 [details]
screenshot of checkerboard

This bug was created from a discussion off of bug 718465.   When loading up pages, you'll sometimes see a checkerboard background appear while the page is still loading.   

This affects perceived user performance.

Tested against sites like nytimes, cnn.com, barnesandnobile.com.

See Screenshot

Repro:
1) HTC Sensation, 04-11-2012 nightly build
2) type in a website, or tap on awesomescreen and select an item out of history
3) As URL is loading (throbber spins), see background checkerboards

Expected:
- instead of checkerboarding on page load, either show a solid background or wait until site loads before showing new content.   Perceived performance win.

Actual:
- checkerboarding background, seems a loss of perceived perf
Is this not fixed with bug 743749 which landed on inbound today?
(Reporter)

Updated

6 years ago
Duplicate of this bug: 744529
blocking-fennec1.0: ? → soft
tracking-fennec: --- → 15+
blocking-fennec1.0: soft → -
Keywords: qawanted
404 checkerboard not found

Reso WFM - Galaxy Nexus (Nightly 05/30, Aurora 05/30, 14.0 Beta 3).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
OS: Mac OS X → Android
Hardware: x86 → ARM
Resolution: --- → WORKSFORME
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.