Closed Bug 744702 Opened 8 years ago Closed 8 years ago

Port |Bug 731494 - Refactor generic code from services/sync into services/common|

Categories

(SeaMonkey :: Sync UI, defect)

defect
Not set

Tracking

(seamonkey2.11 fixed, seamonkey2.12 fixed, seamonkey2.13 fixed)

RESOLVED FIXED
seamonkey2.11
Tracking Status
seamonkey2.11 --- fixed
seamonkey2.12 --- fixed
seamonkey2.13 --- fixed

People

(Reporter: InvisibleSmiley, Assigned: InvisibleSmiley)

References

Details

Attachments

(2 files, 1 obsolete file)

Attached patch patch (obsolete) — Splinter Review
resource://services-sync/ext/Observers.js needs to be changed to resource://services-common/observers.js. There were also some changes to removed-files.in, but I don't think we need them.

Original changeset:
http://hg.mozilla.org/mozilla-central/rev/579f1d93491c
Attachment #614283 - Flags: review?(neil)
Comment on attachment 614283 [details] [diff] [review]
patch

Callek says we should port the removed-files.in changes for completeness. Fortunately that's build system, so you get to ask him for review too ;-)
Attachment #614283 - Flags: review?(neil) → review+
Comment on attachment 614283 [details] [diff] [review]
patch

Callek: Please check the removed-files.in part of the changeset from the initial comment. I don't really understand what needs to go to removed-files.in; all I know is that we don't have a "services-common" directory in any previous release, Aurora, Beta, or trunk. Or are those additions for the non-omni.ja case? :-/
Attachment #614283 - Flags: review?(bugspam.Callek)
Comment on attachment 614283 [details] [diff] [review]
patch

Review of attachment 614283 [details] [diff] [review]:
-----------------------------------------------------------------

They are for the non-omnijar case. So technically not required but I advise/request them anyway.
Attachment #614283 - Flags: review?(bugspam.Callek) → review+
(I marked r+ since I don't mind deferring that to a followup patch, or even for you to land with rs+=me if you think you know what you're doing)
Attaching new patch FTR (removed-files.in additions acquired from FF's current version of the file instead of from the original changeset, which should be safe since services-* is not FF-specific).
Attachment #614283 - Attachment is obsolete: true
Attachment #615037 - Flags: review+
Comment on attachment 615037 [details] [diff] [review]
patch including removed files [Checkin: Comment 6]

http://hg.mozilla.org/comm-central/rev/58e8f7611771
Attachment #615037 - Attachment description: patch including removed files → patch including removed files [Checkin: Comment 6]
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.11
Depends on: 731494
Flags: in-testsuite-
The async.js line was missing in SM 2.10/2.9/(.?.),
but I won't bother to fix it there.
Attachment #627158 - Flags: review?(bugspam.Callek)
Comment on attachment 627158 [details] [diff] [review]
(Bv1) Fully update packaging wrt |Bug 731494 - Refactor generic code from services/sync into services/common|
[Checked in: Comment 11 & 12]

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #627158 - Flags: approval-comm-aurora?
(In reply to Serge Gautherie (:sgautherie) from comment #7)
> The async.js line was missing in SM 2.10/2.9/(.?.),
> but I won't bother to fix it there.

Ftr, that would be a separate (port) bug.
Comment on attachment 627158 [details] [diff] [review]
(Bv1) Fully update packaging wrt |Bug 731494 - Refactor generic code from services/sync into services/common|
[Checked in: Comment 11 & 12]

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #627158 - Flags: approval-comm-beta?
Attachment #627158 - Flags: review?(bugspam.Callek)
Attachment #627158 - Flags: review+
Attachment #627158 - Flags: approval-comm-beta?
Attachment #627158 - Flags: approval-comm-beta+
Attachment #627158 - Flags: approval-comm-aurora?
Attachment #627158 - Flags: approval-comm-aurora+
Comment on attachment 627158 [details] [diff] [review]
(Bv1) Fully update packaging wrt |Bug 731494 - Refactor generic code from services/sync into services/common|
[Checked in: Comment 11 & 12]

http://hg.mozilla.org/comm-central/rev/b3396b2cf032
Attachment #627158 - Attachment description: (Bv1) Fully update packaging wrt |Bug 731494 - Refactor generic code from services/sync into services/common| → (Bv1) Fully update packaging wrt |Bug 731494 - Refactor generic code from services/sync into services/common| [Checked in: Comment 11]
Keywords: checkin-needed
Whiteboard: [c-n: b3396b2cf032 to c-a and c-b]
Comment on attachment 627158 [details] [diff] [review]
(Bv1) Fully update packaging wrt |Bug 731494 - Refactor generic code from services/sync into services/common|
[Checked in: Comment 11 & 12]

https://hg.mozilla.org/releases/comm-aurora/rev/3cd909f360b8
https://hg.mozilla.org/releases/comm-beta/rev/53734735eb6a
Attachment #627158 - Attachment description: (Bv1) Fully update packaging wrt |Bug 731494 - Refactor generic code from services/sync into services/common| [Checked in: Comment 11] → (Bv1) Fully update packaging wrt |Bug 731494 - Refactor generic code from services/sync into services/common| [Checked in: Comment 11 & 12]
Keywords: checkin-needed
Whiteboard: [c-n: b3396b2cf032 to c-a and c-b]
You need to log in before you can comment on or make changes to this bug.