Earlybird scrambles MBOX files and doesn't let user open existing emails

RESOLVED DUPLICATE of bug 730947

Status

Thunderbird
Folder and Message Lists
--
critical
RESOLVED DUPLICATE of bug 730947
6 years ago
3 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({dataloss, regression})

12 Branch
All
Mac OS X
dataloss, regression

Thunderbird Tracking Flags

(thunderbird12-)

Details

(Reporter)

Description

6 years ago
I run into this problem already twice over the last 2 months. Not sure yet why it's happening or how to reproduce it but somehow one of my important folders is not readable anymore in the front-end. I can see the received emails but in the content pane the same text is displayed whatever email I click on. This folder is a subfolder and emails gets moved in there by a message filter (specific To recipient).

So I have checked the MBOX file of the folder and have seen that it is broken. Here an excerpt:


> Ge1AC5ozQwzzTV3dP50DHZ5xQp9qYDl29qf9DQAEsfSgE7s7jjGMUjZ2nBpQvyKT1oAM570Zz26U
> EdzQeKYgb5h8wzmk5ycn6Up/SkHekAcjrTck9DT3U7M847GmKVKjbigY4cUmAWJ64oY9u9OTOQAM
> 0AOO0JnPPpVZf3rZzwDipiQQeoIOKFHHTmgQgXaOOaaASfapJD1A+U01SwA3YJ70DH7SO+RSY25y
> aXOKjmbgAkDccU1uSzQ0Zd9y2ASw6nHFa0nBINVdMRYrYrFnaf4j3qdua6DGW41mApoOT6UgXdIe
> etIeM8igQEjbwaYQ23cCcCmsxAwaY7s7gA4QDpRcCbcyxbM/KSTihJVjjK7AWbue1RljTQxJ6UXA
> crMF+cAsfTtSR8eYz8noKQtzk03dyfSgB8WFkd5Wwg6AdTUbMGb5OSTwKDJnPApuT1AxjvUsY1m - Fri Apr 06 20:14:05 2012
> X-Mozilla-Status: 0001
> X-Mozilla-Status2: 00800000
> X-Mozilla-Keys:                     
> Message-ID: <4F7F3257.80005@hskupin.info>
> Date: Fri, 06 Apr 2012 20:13:43 +0200

As you can see there is no separation between emails. The next one is directly put behind the attachment of a former one without a blank line. There is also missing the 'From' prefix.

All emails following in that mbox file cannot be displayed anymore.
(Reporter)

Comment 1

6 years ago
The last build I have seen this in is Earlybird 03/06. I haven't updated for a while.
(Reporter)

Comment 2

6 years ago
So this could be the same as bug 730947 because I'm using message filters on a POP account.

Comment 3

6 years ago
Yes, very possible.
Also, even if you update to the newest beta of TB12, the folder files will not be fixed automatically, unfortunately. That is how I understand it.
Maybe you could remove the .msf files and try to fix the mbox files in a text editor. Add the missing Froms and linebreaks and then start TB.
(Reporter)

Comment 4

6 years ago
That's what I did this morning. Do we know how many users are affected by this? Would it be possible to create a repair tool?

Comment 5

6 years ago
Henrik, did you ever compact that target folder, or do you have autocompact turned on? We're trying to figure out if this bug still happens; there have been several fixes, but none that would cause such corruption of filtered messages in and of themselves (though cascading errors involving compact could).

We know of three or four users affected by this. Writing a general purpose repair tool is not easy, and I'm busy trying to reproduce, find and fix the bug, if it still is broken.
(Reporter)

Comment 6

6 years ago
I compact the target folder on and off but not regularly. Today I have fixed all instances of brokeness in the MBOX file but I will have a closer look now. 

If it's important for you to get reproduction steps I could try it in the next couple of days. I can use an older build which is affected. Once we have those steps it should be hopefully easy to verify on newer and fixed builds.

Comment 7

6 years ago
(In reply to Henrik Skupin (:whimboo) from comment #6)

> If it's important for you to get reproduction steps I could try it in the
> next couple of days. I can use an older build which is affected. Once we
> have those steps it should be hopefully easy to verify on newer and fixed
> builds.
If you could do that, I'd be very grateful.
tracking-thunderbird12: --- → ?
(Reporter)

Comment 8

6 years ago
I will try to find some time over the weekend or latest early next week.
(Reporter)

Comment 9

6 years ago
David or Mark, something I forgot to ask... would there be a way in getting a little add-on which could assist me in analyzing this bug? It's a bit annoying when I have to go back and forth between thunderbird and the file system in an ongoing basis. Having such a tool which detects an correct MBOX file would be appreciated.

Comment 10

6 years ago
(In reply to Henrik Skupin (:whimboo) from comment #9)
> David or Mark, something I forgot to ask... would there be a way in getting
> a little add-on which could assist me in analyzing this bug? It's a bit
> annoying when I have to go back and forth between thunderbird and the file
> system in an ongoing basis. Having such a tool which detects an correct MBOX
> file would be appreciated.

There's no add-on that I know of that verifies the MBOX file, and verifying the MBOX file w/o using the .msf file is especially challenging. Verifying that the .msf file and the mbox file are in sync is more doable. In fact, one simple test would be to verify that repairing the .msf file gives the same msg hdr information as the original .msf file had. I'll try to see if that's doable from an extension.
Assuming this is just another instance of bug 730947 for now, so not tracking, but if you believe otherwise please let us know asap.
tracking-thunderbird12: ? → -
(Reporter)

Comment 12

6 years ago
Good news. I was able to easily reproduce this bug in an Earlybird version 12a2 from March 6th as used above for filing this bug. I will nail down the steps to reproduce and will come back here with the details. Also I will re-test in the latest 12.0 beta version if I can still reproduce the issue.
(Reporter)

Comment 13

6 years ago
I have to correct myself. I only have seen this problem in the final target folder when I moved a filtered (moved) email manually to another folder. I will continue testing if I can make the mbox file of the filters target folder invalid.

Comment 14

6 years ago
Henrik has banged on this quite a bit, and we're agree this is most likely a dup.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 730947
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.