Closed Bug 74471 Opened 24 years ago Closed 24 years ago

Hitting stop button while downloading pop mssgs-N6 asserts, stop button disappears

Categories

(MailNews Core :: Networking: POP, defect)

x86
Linux
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: sheelar, Assigned: pavlov)

References

Details

(Keywords: crash, regression, Whiteboard: crashes [@nsImageBoxFrame::UpdateImage])

Attachments

(2 files)

buildid:  2001-02-04-08 linux

Steps to recreate crash:

Create a new pop account in mail from accounts and settings in an existing 
profile.
Hit stop button while it is still downloading messages and not yet compelete.
Results in crash.

Stack trace for the crash below :  incident id =28576385
 
   libgklayout.so + 0xf3dc4 (0x40d85dc4) 
                                            
     
   libgklayout.so + 0xf417c (0x40d8617c) 
                                            
     
   libgklayout.so + 0x3985d (0x40ccb85d) 
                                            
     
   libgklayout.so + 0x409f1 (0x40cd29f1) 
                                            
     
   libgklayout.so + 0x41029 (0x40cd3029) 
                                            
     
   libgklayout.so + 0x41029 (0x40cd3029) 
                                            
     
   libgklayout.so + 0x411ac (0x40cd31ac) 
                                            
     
   libgklayout.so + 0xb9076 (0x40d4b076) 
                                            
     
   libgkcontent.so + 0x1c5c0b (0x40b98c0b) 
                                            
     
   libgklayout.so + 0x6374b (0x40cf574b) 
                                            
     
   libgkcontent.so + 0x13971a (0x40b0c71a) 
                                            
     
   libgkcontent.so + 0x592d4 (0x40a2c2d4) 
                                            
     
   libgkcontent.so + 0x5583f (0x40a2883f) 
                                            
     
   libgklayout.so + 0x6451e (0x40cf651e) 
                                            
     
   libgklayout.so + 0x642dc (0x40cf62dc) 
                                            
     
   libgkview.so + 0x399a (0x40ef599a) 
                                            
     
   libgkview.so + 0xce9e (0x40efee9e) 
                                            
     
   libgkview.so + 0x334d (0x40ef534d) 
                                            
     
   libwidget_gtk.so + 0x1a60a (0x404ca60a) 
                                            
     
   libwidget_gtk.so + 0x1a535 (0x404ca535) 
                                            
     
   libwidget_gtk.so + 0x1a690 (0x404ca690) 
                                            
     
   libwidget_gtk.so + 0x1b2df (0x404cb2df) 
                                            
     
   libwidget_gtk.so + 0x1ee8f (0x404cee8f) 
                                            
     
   libwidget_gtk.so + 0x153c7 (0x404c53c7) 
                                            
     
   libwidget_gtk.so + 0x1511c (0x404c511c) 
                                            
     
   libgdk-1.2.so.0 + 0x174db (0x406304db) 
                                            
     
   libglib-1.2.so.0 + 0x10186 (0x40660186) 
                                            
     
   libglib-1.2.so.0 + 0x10751 (0x40660751) 
                                            
     
   libglib-1.2.so.0 + 0x108f1 (0x406608f1) 
                                            
     
   libgtk-1.2.so.0 + 0x8c5b9 (0x405855b9) 
                                            
     
   libwidget_gtk.so + 0xd5ec (0x404bd5ec) 
                                            
     
   libnsappshell.so + 0xd76a (0x4046276a) 
                                            
     
   mozilla-bin + 0x60b4 (0x0804e0b4) 
                                            
     
   mozilla-bin + 0x6945 (0x0804e945) 
                                            
     
   libc.so.6 + 0x189cb (0x402479cb)
adding keywords so that this bug can get fixed and changing the severity too.
Adding two bugs that this bug blocks from verifying.
Blocks: 67799, 71666
Severity: normal → critical
QA Contact: esther → sheelar
No longer blocks: 67799
resolved worksforme using 2001040311 on linux
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → WORKSFORME
Re-opening, seeing the crash again with today's linux debug build, 
was working yesterday. 

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
reassigning to sspitzer, cc naving
Assignee: naving → sspitzer
Status: REOPENED → NEW
does anyone have a stack trace with symbols?
I downloaded commercial build 2001-04-04-14 on linux and I don't see the crash.
Removing the blocker since I am not crashing on today's build and I can verify 
bug 71666
No longer blocks: 71666
does the call to GetURI() return a failure code?

I'd do something like this:

rv = mImageRequest->GetURI(getter_AddRefs(requestURI));
NS_ASSERTION(NS_SUCCEEDED(rv) && requestURI,"no request URI");
if (NS_FAILED(rv) || !requestURI) return;

also, check if this crash is showing up on talkback?

bullet proofing isn't a bad thing, but we should also figure out why this is
happening.

pav / hyatt, does this ring and bells?
stack trace with symbols

Program received signal SIGSEGV, Segmentation fault.
0x41c2b72f in nsImageBoxFrame::UpdateImage (this=0x87bdf74,
    aPresContext=0x828e850, aResize=@0xbfffe6f8) at nsImageBoxFrame.cpp:333
333         requestURI->Equals(srcURI, &eq);

#0  0x41c2b72f in nsImageBoxFrame::UpdateImage (this=0x87bdf74,
    aPresContext=0x828e850, aResize=@0xbfffe6f8) at nsImageBoxFrame.cpp:333
#1  0x41c2bc9c in nsImageBoxFrame::DidSetStyleContext (this=0x87bdf74,
    aPresContext=0x828e850) at nsImageBoxFrame.cpp:462
#2  0x41b05c16 in nsFrame::SetStyleContext (this=0x87bdf74,
    aPresContext=0x828e850, aContext=0x89d3690) at nsFrame.cpp:474
#3  0x41b144e0 in FrameManager::ReResolveStyleContext (this=0x8297d20,
    aPresContext=0x828e850, aFrame=0x87bdf74, aParentContext=0x8889358,
    aParentContent=0x865e610, aAttrNameSpaceID=-1, aAttribute=0x0,
    aChangeList=@0xbfffee10, aMinChange=5, aResultChange=@0xbfffe9d8)
    at nsFrameManager.cpp:1633
#4  0x41b14e3f in FrameManager::ReResolveStyleContext (this=0x8297d20,
    aPresContext=0x828e850, aFrame=0x87bdee4, aParentContext=0x89ae1e8,
    aParentContent=0x84af900, aAttrNameSpaceID=-1, aAttribute=0x0,
    aChangeList=@0xbfffee10, aMinChange=5, aResultChange=@0xbfffeba8)
    at nsFrameManager.cpp:1774
#5  0x41b14e3f in FrameManager::ReResolveStyleContext (this=0x8297d20,
    aPresContext=0x828e850, aFrame=0x87bde54, aParentContext=0x866cd20,
    aParentContent=0x0, aAttrNameSpaceID=-1, aAttribute=0x0,
    aChangeList=@0xbfffee10, aMinChange=5, aResultChange=@0xbfffeca8)
    at nsFrameManager.cpp:1774
#6  0x41b15071 in FrameManager::ComputeStyleChangeFor (this=0x8297d20,
    aPresContext=0x828e850, aFrame=0x87bde54, aAttrNameSpaceID=-1,
---Type <return> to continue, or q <return> to quit---
    aAttribute=0x0, aChangeList=@0xbfffee10, aMinChange=0,
    aTopLevelChange=@0xbfffee9c) at nsFrameManager.cpp:2019
#7  0x41bd14e6 in nsCSSFrameConstructor::ContentStatesChanged (this=0x8297408,
    aPresContext=0x828e850, aContent1=0x84af900, aContent2=0x0)
    at nsCSSFrameConstructor.cpp:9609
#8  0x414a3fd5 in StyleSetImpl::ContentStatesChanged (this=0x8297318,
    aPresContext=0x828e850, aContent1=0x84af900, aContent2=0x0)
    at nsStyleSet.cpp:1259
#9  0x41b4aa49 in PresShell::ContentStatesChanged (this=0x82974a0,
    aDocument=0x826ef40, aContent1=0x84af900, aContent2=0x0)
    at nsPresShell.cpp:4413
#10 0x413bba71 in nsXULDocument::ContentStatesChanged (this=0x826ef40,
    aContent1=0x84af900, aContent2=0x0) at nsXULDocument.cpp:1518
#11 0x4126d88d in nsEventStateManager::SetContentState (this=0x838c428,
    aContent=0x0, aState=1) at nsEventStateManager.cpp:3075
#12 0x412660e5 in nsEventStateManager::PostHandleEvent (this=0x838c428,
    aPresContext=0x828e850, aEvent=0xbffff600, aTargetFrame=0x87bde54,
    aStatus=0xbffff4fc, aView=0x8297028) at nsEventStateManager.cpp:1391
#13 0x41b4c56f in PresShell::HandleEventInternal (this=0x82974a0,
    aEvent=0xbffff600, aView=0x8297028, aFlags=1, aStatus=0xbffff4fc)
    at nsPresShell.cpp:5131
#14 0x41b4bfa8 in PresShell::HandleEvent (this=0x82974a0, aView=0x8297028,
    aEvent=0xbffff600, aEventStatus=0xbffff4fc, aForceHandle=1,
---Type <return> to continue, or q <return> to quit---
    aHandled=@0xbffff4a0) at nsPresShell.cpp:5038
#15 0x41d9ab1b in nsView::HandleEvent (this=0x8297028, event=0xbffff600,
    aEventFlags=28, aStatus=0xbffff4fc, aForceHandle=1, aHandled=@0xbffff4a0)
    at nsView.cpp:366
#16 0x41da6865 in nsViewManager::DispatchEvent (this=0x8296ee0,
    aEvent=0xbffff600, aStatus=0xbffff4fc) at nsViewManager.cpp:1994
#17 0x41d9a194 in HandleEvent (aEvent=0xbffff600) at nsView.cpp:67
#18 0x40833a68 in ?? ()
   from /export/naving/trunk/mozilla/dist/bin/components/libwidget_gtk.so
#19 0x408336ac in ?? ()
   from /export/naving/trunk/mozilla/dist/bin/components/libwidget_gtk.so
#20 0x40833b20 in ?? ()
   from /export/naving/trunk/mozilla/dist/bin/components/libwidget_gtk.so
#21 0x40834e95 in ?? ()
   from /export/naving/trunk/mozilla/dist/bin/components/libwidget_gtk.so
#22 0x4083b710 in ?? ()
   from /export/naving/trunk/mozilla/dist/bin/components/libwidget_gtk.so
#23 0x4082b251 in ?? ()
   from /export/naving/trunk/mozilla/dist/bin/components/libwidget_gtk.so
#24 0x4082adf4 in ?? ()
   from /export/naving/trunk/mozilla/dist/bin/components/libwidget_gtk.so
#25 0x409b700b in ?? () from /usr/lib/libgdk-1.2.so.0
#26 0x409e1be6 in ?? () from /usr/lib/libglib-1.2.so.0
---Type <return> to continue, or q <return> to quit---
#27 0x409e21a1 in ?? () from /usr/lib/libglib-1.2.so.0
#28 0x409e2341 in ?? () from /usr/lib/libglib-1.2.so.0
#29 0x4090c209 in ?? () from /usr/lib/libgtk-1.2.so.0
#30 0x4081fcfa in ?? ()
   from /export/naving/trunk/mozilla/dist/bin/components/libwidget_gtk.so
#31 0x407461e4 in ?? ()
   from /export/naving/trunk/mozilla/dist/bin/components/libnsappshell.so
#32 0x8054e4d in main1 (argc=4, argv=0xbffffb84, nativeApp=0x0)
    at nsAppRunner.cpp:1021
#33 0x8055b7a in main (argc=4, argv=0xbffffb84) at nsAppRunner.cpp:1316
From talkback found 15 incidents of crash @nsImageBoxFrame::UpdateImage
Whiteboard: crashes [@nsImageBoxFrame::UpdateImage]
ok, I'll do some debugging.

If I can't figure it out, I'll get some bullet proofing in, and then hand this
bug off to the rightful owner.
Status: NEW → ASSIGNED
The same crash occurs on mac also. See #74212
*** Bug 74212 has been marked as a duplicate of this bug. ***
bullet proofing may cause the "stop" button to not appear. 
r=pavlov
I object morally to not having Pav fix libpr0n, but I guess this is better than
crashing.  Blah.

sr=shaver.
fix checked in.

now we assert.  according to naving, the stop button will disappear.

update summary and re-assign to pavlov, to investigate.
Assignee: sspitzer → pavlov
Status: ASSIGNED → NEW
Summary: Hitting stop button while downloading pop mssgs-N6 crashes → Hitting stop button while downloading pop mssgs-N6 asserts, stop button disappears
Adding 'mailtrack' keyword.
Keywords: mailtrack
Status: NEW → RESOLVED
Closed: 24 years ago24 years ago
Resolution: --- → WORKSFORME
resolving worksforme.  this is a dup of some bug i fixed a while ago.  no
assert.
verifying worksforme based on 2001-05-14 23:48 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: