If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

pdf downloads not working

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Robert, Unassigned)

Tracking

11 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

Tried to download pdf files as I've done for ages


Actual results:

Nothing.  The .pdf URL appears in the address bar, but nothing happens


Expected results:

Usually the pdf file starts downloading....as I've done without a problem for years, until today....and I did NOT download or change any software or settings, except for an automatic upgrade of and by Firefox yesterday....!! I assume that should be the culprit?!?
I will try and reproduce, but next time, Robert, to save some time for us, could you please also provide the url of one such pdf?
Testing with http://www.hort.purdue.edu/ext/HO-4.pdf and either FF 11 or FF 12, I cannot reproduce the issue.
(Reporter)

Comment 3

6 years ago
(1) As requested, the pdf files that did NOT download using Firefox:

http://www.lbie.com/07_Basalt_Needled_Felt.pdf
http://www.lbie.com/08_Basalt_Surface_Tissue.pdf
http://www.thirdwave.de/3w/tech/armor/carbonfibre.pdf
http://www.globalspill.com/uploads/downloads/page81boom-accessoriestidal-compensatorstowing-bridalsmagnetic-boom-connectors.pdf
http://www.slickbar.com/pdf/slickbar/mk_rb_repair_manual.pdf
http://www.slickbar.com/slickbar/boom_accessories/MidPointTConnector.pdf
http://www.epa.gov/osweroe1/docs/oil/ncp/SorbSolidifierFactsheet2007finalV6.pdf

(2) I managed to get the files by opening Acrobat and creating a pdf file from the webpage URL from within Acrobat.

(3) I downloaded the pdf files using Safari without a problem.

Ergo, something must have created this problem with Firefox when Firefox upgraded automatically yesterday. It's NOT the pdf files, it's not my Mac, and it's not any change in settings, unless Firefox upgraded and changed something outside my control.

The problem persists WITH FIREFOX ALONE.

Comment 4

6 years ago
(In reply to Robert from comment #3)
> http://www.lbie.com/07_Basalt_Needled_Felt.pdf

Works correctly with FF 11.0 on Fedora 16.
In the Firefox Preferences under "Applications", what is listed for PDF files?
If you keep the "Downloads" window open (Tools > Downloads), is anything displayed when you try to start a PDF download?
Summary: pdf downloads → pdf downloads not working
(Reporter)

Comment 5

6 years ago
I wrote what happens, or actually, does not happen.

But, in the meantime pdf downloads work again as before. I simply trashed Firefox.app and downloaded it again. Nothing else.

Comment 6

5 years ago
CLosing as per last comment (not reproducible).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.