about:home can get cut off above the addons section

RESOLVED DUPLICATE of bug 744555

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 744555
6 years ago
6 years ago

People

(Reporter: AdrianT, Unassigned)

Tracking

14 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 614334 [details]
logs when loading about:home

Fennec/14.0a1 2012-04-10
Device: Motorola Droid 2(Android 2.3)

I have not been able to isolate steps to reproduce this but from time to time the Fennec profile gets in a state where the about:home is cut off above the addons section. 

The page will be displayed this way until the user clears the data creating a new profile.

The issue has been seen on different phones on different builds over the last week but we were unable to isolate a reproducibility pattern. Also it does not matter if there is or isn't a "Tabs from last time" section.

Looking through the logs no errors could be seen when loading about:home
What do you mean? Can you show a screenshot?

Remember, if there are no add-ons, the add-ons section does not appear. Currently, there are no recemmended add-ons. When the app checks for the latest list of recommneded add-ons and none are returned, the add-ons section is removed.

That is happening now because of bug 744555.
(Reporter)

Comment 2

6 years ago
Created attachment 614341 [details]
about:home before and after profile clear
Yeah, this is a dupe of bug 744555. It's not cutoff. There are just no add-ons to show.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 744555
(Reporter)

Comment 4

6 years ago
Created attachment 614343 [details]
logs from the update process

I have been able to reproduce the issue 3 consecutive times following the steps:
1. Install an older version of Nightly( I used the one from yesterday)
2. Look for updates and download them.
3. Install the updates.
4. After updates install choose the "Open" button.

Results:
The recommended addons section will be missing. After a clear profile the updates are displayed.

I am not sure this is a dupe of Bug 744555 as the recommended addons section is displayed after a profile clear - and after a profile clear there should not be other addons installed.
when you clear a profile, Fennec uses a hard coded list of recommended add-ons to display on about:home. These are not already istalled add-ons. They are add-ond you could install.

Periodically, Fennec will ask the AMO server for a new list of recommended add-ons. If none are recommended, an empty list is returned.

Fennec will use the new list to display add-ons on about:home. If the list is empty, we show no add-ons.

That appears to be what is happening in your screen shot.
You need to log in before you can comment on or make changes to this bug.