If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Viewport upper section moves down when changing orientation

RESOLVED WONTFIX

Status

()

Firefox for Android
General
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: Paul Feher, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Nightly Fennec 14.0a1 (2012-04-12)
Device: HTC Desire Z
OS: Android 2.3.3

Steps to reproduce:
1. Load msnbc.com
2. Scroll the page down.
3. Rotate the device.

Expected:
The viewport upper section stays the same in portrait and landscape mode.

Actual
The viewport upper section slips below the initial position when the device changes orientation from portrait to landscape mode.

NOTE: Using Dolphin and stock browser this issue is not reproducible.
This is because the menu items at the very top of msnbc.com get rearranged to take up the extra width in landscape mode, shifting everything else up. Our scroll position remains the same in pixels from top of page, it's the page that changes under us.

You don't see this on the stock browser because their behaviour is different on rotation. It seems like they don't maintain the top-left corner on rotation like we do (you can see this by going to some random text-filled website and rotating the device). It just so happens that on msnbc.com the amount they shift the scroll position on rotation cancels out the amount that the page changes by on msnbc.com.

I'm going to mark this as WONTFIX but feel free to reopen if you think this needs further looking at.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.