Closed Bug 744756 Opened 8 years ago Closed 4 years ago

Feature Request - use email filters across multiple accounts

Categories

(SeaMonkey :: MailNews: Backend, enhancement)

SeaMonkey 2.8 Branch
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 34973

People

(Reporter: sergeant82d.bugzilla, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20120315 Firefox/11.0 SeaMonkey/2.8
Build ID: 20120315222422

Steps to reproduce:

Setting up filters to move incoming email into specific folders automatically.  The implemented function worked perfectly, no complaints at all. However I would like to have the ability to apply any given, established filter across multiple email accounts.


Actual results:

I receive email messages from numerous senders, on multiple accounts. I set up filters to move these messages from their respective accounts, into one folder on my machine, for organizational purposes. I have to create the same filter - and hope I get it right, for >25 "from" addresses.... - for more than one account.


Expected results:

When selecting Tools/Message Filters, instead of having the drop-down box "Filters for:" on that form, move it to the "Edit" form, and using a dynamically created list, be able to add a check box (or other selection tool) to enable the filter for any combination of accounts.
Don't really need to move the "Filters for:" drop box if you can select and save the info on each filter in the list, based on it's focus in that window on the main form.
Severity: normal → enhancement
Component: General → MailNews: General
OS: Linux → All
QA Contact: general → mail
Hardware: x86 → All
Component: MailNews: General → MailNews: Backend
QA Contact: mail → mailnews-backend
Bug 34973 - (GlobalFilters) Global message filter option to use a filter shared across accounts
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: GlobalFilters
You need to log in before you can comment on or make changes to this bug.