zombie document held alive by nsIDOMGeoPositionOptions

VERIFIED DUPLICATE of bug 731875

Status

()

Core
Geolocation
VERIFIED DUPLICATE of bug 731875
6 years ago
6 years ago

People

(Reporter: mccr8, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink])

(Reporter)

Description

6 years ago
I happened to notice this while investigating another leak.  I went to Google Maps to get directions, it popped up the little dialogue asking if I wanted to let Google Maps know my location, I clicked yes.  It found my location, showed a route, and I closed the tab.

Some time later, while using the about:cc addon, I noticed that the Google Maps document was still alive (along with its compartment).  Somehow the document is being kept alive by the nsIDOMGeoPositionOptions.

0x12a3e9000 [rc=6] nsDocument normal (xhtml) http://maps.google.com/maps (etc)
    Roots: 1
        0x132fa0f90 [rc=2] root nsXPCWrappedJS (nsIDOMGeoPositionOptions)
0x124cb5800 [rc=6] nsDocument normal (xhtml) http://maps.google.com/maps  (etc)
    Roots: 1
        0x132fa0f90 [rc=2] root nsXPCWrappedJS (nsIDOMGeoPositionOptions)

Comment 1

6 years ago
I had suspicions that the doorhanger was to blame in bug 731875 but I never got around to investigating it.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 731875
V.Duplicate
No longer blocks: 728407
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.