Closed Bug 744976 Opened 10 years ago Closed 10 years ago

Downloads fail silently when the system sleeps

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: reuben, Unassigned)

References

Details

Nightly 2012-04-12 on ICS

STR:
1) Start a relatively large download (enough to last longer than the system sleep time)
2) Lock screen, leave phone idle for a couple minutes.
3) Unlock and focus Fennec

Download is lost.
Can you provide to this bug, capture and attach a log from when your device sleeps and what happens during that period? You can use alogCat (https://play.google.com/store/apps/details?id=org.jtb.alogcat), or by running the DDMS utility from within the Android SDK (http://developer.android.com/sdk/index.html), thanks.

As well, if you're on WiFi, what is your Android system setting WiFi sleep setting? Do you happen to keep WiFi on during sleep set as: only when plugged in? never? or always?

Lastly, can you expand on lost?
(In reply to Aaron Train [:aaronmt] from comment #1)
> Can you provide to this bug, capture and attach a log from when your device
> sleeps and what happens during that period?

Sure. I was at college when I spotted this so couldn't get a log. I can't seem to reproduce the same problem now: the download is still there, but it stalls a few seconds after I lock my screen. I'll attach a log when I'm able to reproduce the same problem.

> As well, if you're on WiFi, what is your Android system setting WiFi sleep
> setting? Do you happen to keep WiFi on during sleep set as: only when
> plugged in? never? or always?

Always.

> Lastly, can you expand on lost?

The download badge in the notification area is gone, there's no indication that a download was paused or ended when I reopen Fennec after sleep, and the file is not written (not even partially) to downloads.
Sounds like we need resume support which is covered in bug 741655.
tracking-fennec: --- → ?
Depends on: 741655
I can't reproduce this anymore. Long downloads stall, but no longer disappear.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
tracking-fennec: ? → ---
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.