Share should share page title as well as URL

RESOLVED FIXED in Firefox 21

Status

()

Firefox for Android
General
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Paul [pwd], Assigned: rnewman)

Tracking

({polish})

Trunk
Firefox 21
ARM
Android
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20120412 Firefox/14.0a1
Build ID: 20120412030726

Steps to reproduce:

Opera for Android does this. It's convenient and useful, I'm not really sure why Fennec opts to only share the URL.
(Reporter)

Updated

6 years ago
OS: Windows 7 → Android
Hardware: x86 → ARM
I'm not able to reproduce what you are seeing.

The title of the webpage is in the subject when you send off an email.  Opera doesn't show the title in twitter; neither do we since there's limited space.

Can you be more specific in where you are seeing the issue please?
(Reporter)

Comment 2

6 years ago
You're right, Tweetdeck, Tweakdeck and Twitter are shared without page title, while Whatsapp shares the page title.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Assignee)

Comment 3

5 years ago
Pocket also doesn't get the page title. But it doesn't when sharing a page from the Android 4.2 "Internet" browser, either.

As we found in Bug 799615, there are a bunch of different ways to send pages, some of which work better than others. I would like to explore this further at some point, because I think we might be able to make this work.

So if nobody minds, I'm going to reopen this and do some investigation.
Assignee: nobody → rnewman
Status: RESOLVED → REOPENED
Ever confirmed: true
Keywords: polish
Resolution: INVALID → ---
(Assignee)

Updated

5 years ago
Status: REOPENED → ASSIGNED
Summary: Share should share page title rather than just the URL → Share should share page title as well as URL
(Assignee)

Comment 4

5 years ago
Created attachment 710075 [details] [diff] [review]
Part 0: rewrite openUriExternal. v1

Mark, please review or dispatch appropriately!

This part 0 rewrites openUriExternal to:

* Use early returns
* Eliminate C++-style aFoo naming
* Separate intent creation from activity launching
* Use more efficient/library code for things like query parsing
* Improve readability and style
* Add Javadocs and comments

It builds; tomorrow I will test it.
Attachment #710075 - Flags: review?(mark.finkle)
(Assignee)

Comment 5

5 years ago
Created attachment 710077 [details] [diff] [review]
Part 1: add title. v1

On top of that refactoring, the one-line change. Yes, it's a one-line change, but now we can read the function and understand what it's doing ;)

Again, I will test this tomorrow.
Attachment #710077 - Flags: review?(mark.finkle)
Attachment #710075 - Flags: review?(mark.finkle) → review+
Attachment #710077 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 6

5 years ago
   https://hg.mozilla.org/integration/mozilla-inbound/rev/9e3edc87a446
   https://hg.mozilla.org/integration/mozilla-inbound/rev/8ac096b24cb0
Target Milestone: --- → Firefox 21
https://hg.mozilla.org/mozilla-central/rev/9e3edc87a446
https://hg.mozilla.org/mozilla-central/rev/8ac096b24cb0
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → FIXED
Depends on: 839580
You need to log in before you can comment on or make changes to this bug.