[airmozilla] Safari video issues

RESOLVED FIXED

Status

Websites
air.mozilla.com
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: rbillings, Assigned: richard)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
Not all Air Mozilla videos play on Safari. I was able to watch Firefox Flix but not WebFWD, dev tools, rock your firefox or the history of Mozilla.

1) https://air-dev.allizom.org/2012/04/webfwd-fund/
2) Play on Safari v 5.1.3 or 5.1.5

expected: video plays
actual: no video plays [* others testing were able to view video after 1+ min delay on Safari]
(Assignee)

Comment 1

6 years ago
At the time you tested, Firefox Flix was a live stream delivered via the BitGravity CDN.  Format is determined by device detection done at the BitGravidy CDN.

WebFWD Fund video was a Vid.ly link.  Should also be doing device (browser) detection and feeding an appropriate format.  Served from Vid.ly.    We're currently standardizing on this delivery method for archived Air Mozilla videos to avoid needing to embed a flash player.

FWIW, that video starts for me in about 10 seconds in Safari (the start is the appearance of the "One Mozilla logo, not the first appearance of Diane and Pascal).
(...took me MUCH longer than that to figure out where Apple hid the address bar in the new Safari).  Start times will likely be proportional to connection speed and load.

The DevTools, Rock Your Firefox, and History of Mozilla are older videos served from videos.mozilla.org (via the Edgecast CDN) that appear to have been added to the air-dev site as an (incomplete) html-5 video tag that has only a single (.ogv) source.   I doubt that would ever work on most browsers other than Firefox.   On the production site we'll be adding videos like these from our "back catalog" by pouring them through vid.ly first. So they will work the same way as the WebFWD Fund video.

What were the connection speeds of the various testers?

Comment 2

6 years ago
Tested on a 30/10 cable modem
(Assignee)

Comment 3

6 years ago
We don't have any way to do an A/B test on this because we've never had archived recordings available on the old AirMo site.    Not quite sure how to proceed debugging this.

Comment 4

6 years ago
Some more info for you. I think this issue is with vidly not airmozilla or maybe it's how we embed vidly?

I can reproduce this behavior using Mac safari 5.1.5 on:
https://firefoxflicks.mozilla.org/en-US/video/twilight/
- after clicking play the spinner loader either:
 - spins forever
 - just freezes

But if i go directly to vidly for the same video it loads quickly and everything works:

http://vid.ly/6d9t7l

I think the next step would be to open a support ticket with vidly with the above two urls. Hopefully they can diagnose.
(Assignee)

Comment 5

6 years ago
I've done a little more testing and the results are puzzling.

I had two AirMo posts that were not playing at all.  They would show the poster image but would never start.

I re-transcoded them both using vid.ly.   I replaced one and it's working fine now.  I went to replace the second and found it working reliably without replacing the file.

I'll watch both of those over the next couple of days and try to determine if this is an intermittent problem or if the transcoding does vary from instance to instance (of the same transcoded file.
(Reporter)

Comment 6

6 years ago
Are there any updates to this issue?
(Assignee)

Comment 7

6 years ago
I'm not able to reproduce the problem on the production site.
This seemed to be a weird problem with scaling objects in CSS, which has since been fixed with some updates to the style sheet.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

6 years ago
I'm currently unable to view *any* video from air.mozilla.org on Safari. I'll let someone else make the call if this can stay open or should be closed.
You need to log in before you can comment on or make changes to this bug.