Implement API for welcome email on ID newsletter sign up from

RESOLVED FIXED in Future

Status

www.mozilla.org
General
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Jessilyn Davis (Maternity Leave), Assigned: pascalc)

Tracking

unspecified
Future
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa+] [sp-2012-08-28] u=dev c=email)

(Reporter)

Description

6 years ago
Hey Chris,

We're hoping to launch the ID newsletter sign up form by end of May. James has helped with the API implementation of the past newsletter sign up forms. This sign up form should work like the other localized versions of the sign up form.

Can you help guide this bug in the right direction and let us know a feasible date for implementation?

This is the API bug to go along with the localization of the form and creation of: https://www.mozilla.org/id/newsletter (Bug 745029)

How form + API should work upon submitting an email address:
LANGUAGE_ISO2 = id
MOZILLA_AND_YOU_FLG = Y
MOZILLA_AND_YOU_DATE = date submitted
COUNTRY_ = country selected
"Welcome Email - ID" (ID: 6383) is sent to the email subscriber.
Subscriber is added to the "Double_Opt_In" data extension

Upon clicking on the confirmation link in the email (https://www.mozilla.org/id/newsletter/confirm/%%token%%/):
Subscriber should be added to the "Confirmation" Data Extension Table

Updated

6 years ago
OS: Mac OS X → All
Hardware: x86 → All
Target Milestone: --- → 2.5

Updated

6 years ago
Assignee: chrismore.bugzilla → nobody
(Reporter)

Comment 1

6 years ago
Hey Chris - I just wanted to check in on this bug to see if it was still on your radar for this quarter. Do you have a better idea of an implementation date?  Pascal should have the l10n for this locale ready by end of this week on dev.

Thanks!
Assigning over to Rik. We can prioritize this with other email signup/pref center work.
Assignee: nobody → anthony
Target Milestone: 2.5 → Future
I've not yet interacted with ExactTarget and basket so I'll get a first contact with a similar request in bug 746792. I'll keep you updated after working on this other bug.
(Reporter)

Comment 4

6 years ago
The l10n pages are ready on dev for API work.
(Assignee)

Comment 5

6 years ago
I talked to Rik and I am going to take this one :)
Assignee: anthony → pascalc
(Reporter)

Comment 6

6 years ago
Great Pascal! :)

Please let me know if you have any questions or are missing any information.  Also please let me know a goal date for implementation.

In case it's helpful, this is the external key for firing the ID confirmation email from Exact Target:

id_confirmation_email


Thanks! :)

Jess
(Reporter)

Comment 7

6 years ago
This form function should work exactly like the French, German, Spanish, and Portuguese forms - except for the name of the email fired should be "id_confirmation_email" instead of "fr_confirmation_email", "de_confirmation_email", "es_confirmation_email", and "pt_br_confirmation_email"

Does this help?
(Assignee)

Comment 8

6 years ago
I am deep into Firefox 14 release which has its first complex bedrock-based localization for the whatsnew page, I'll see if I can work on that next week.
(Reporter)

Comment 9

6 years ago
Hey Pascal! Thanks for the update. How'd the FF14 bedrock relase go?

Please let me know your status and what you think about the timeline on this bug.

Comment 10

6 years ago
Pascal: Can you give us an update on when you will have time to implement this?
(Assignee)

Comment 11

6 years ago
this is implemented along with the bug for Indonesian (https://bugzilla.mozilla.org/show_bug.cgi?id=745011#c6), this requires manual testing for potential regressions since unfortunately we never set up PHPUnit or SimpleUnit on our PHP codebase for dynamics parts of our code.

Comment 12

6 years ago
Pascal: Where can we go to test it and have QA review the interaction with Jess verifying the results?
Whiteboard: [qa+]
(Assignee)

Comment 13

6 years ago
This bug is in the same state as Russian:
https://bugzilla.mozilla.org/show_bug.cgi?id=745011#c9

What is left to do are settings in the email service I don't have access to.

Comment 14

6 years ago
cmore - can this be assigned to Anthony or Mkelly to finalize the basket/ExactTarget portion.

Updated

6 years ago
Whiteboard: [qa+] → [qa+] [sp-2012-08-28] u=dev c=email

Comment 15

6 years ago
Winston: Malexis added this to our sprint schedule and we will get it on an upcoming sprint. We have our next planning meeting tomorrow.
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org

Updated

6 years ago
Depends on: 788473
I opened bug 788473 to track this as it's the same root cause for both newsletters.
As soon as Jess gives us the go after testing on www.allizom.org, we can push this.
(Reporter)

Comment 18

6 years ago
Ran through testing - all looks good!

Please let me know when this is live on production.

Thanks!
(Assignee)

Comment 19

6 years ago
pushed in r109418
(Reporter)

Comment 20

6 years ago
I have ran tests on existing locales and this new locale. All is working perfectly!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.