Last Comment Bug 745066 - Add comments documenting the declaration of nsSVGFilterInstance, its methods, and its members
: Add comments documenting the declaration of nsSVGFilterInstance, its methods,...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Jonathan Watt [:jwatt] (back in October - email directly if necessary)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 19:49 PDT by Jonathan Watt [:jwatt] (back in October - email directly if necessary)
Modified: 2012-04-14 06:23 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (20.48 KB, patch)
2012-04-13 05:06 PDT, Jonathan Watt [:jwatt] (back in October - email directly if necessary)
longsonr: review+
Details | Diff | Splinter Review

Description Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-04-12 19:49:25 PDT
Understanding nsSVGFilterInstance is a bit of a nightmare since it is so poorly documented. We should add comments documenting the declaration of nsSVGFilterInstance, its methods, and its members.
Comment 1 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-04-13 05:06:19 PDT
Created attachment 614747 [details] [diff] [review]
patch
Comment 2 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-04-13 05:07:23 PDT
I also removed a few bits of dead code that I noticed in passing.
Comment 3 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-04-13 06:33:18 PDT
Thanks. Pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/dc0b57deb507
Comment 4 Marco Bonardo [::mak] 2012-04-14 06:23:23 PDT
https://hg.mozilla.org/mozilla-central/rev/dc0b57deb507

Note You need to log in before you can comment on or make changes to this bug.