Last Comment Bug 745068 - Minor front-end cleanups
: Minor front-end cleanups
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla14
Assigned To: Nicholas Nethercote [:njn]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 19:54 PDT by Nicholas Nethercote [:njn]
Modified: 2012-04-16 08:36 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (7.69 KB, patch)
2012-04-12 19:54 PDT, Nicholas Nethercote [:njn]
no flags Details | Diff | Splinter Review
patch, v2 (8.77 KB, patch)
2012-04-12 22:47 PDT, Nicholas Nethercote [:njn]
jorendorff: review+
Details | Diff | Splinter Review

Description Nicholas Nethercote [:njn] 2012-04-12 19:54:52 PDT
Created attachment 614665 [details] [diff] [review]
patch

Assorted front-end cleanups:  
- Remove two dead methods.
- Remove some unnecessary #includes.
- Fix a broken cross-reference in a comment.
- Document the TreeContext/BytecodeEmitter split.
Comment 1 Nicholas Nethercote [:njn] 2012-04-12 22:47:16 PDT
Created attachment 614687 [details] [diff] [review]
patch, v2

This version also removes optimizedClosure() because it's dead as a doornail.
Comment 2 Nicholas Nethercote [:njn] 2012-04-15 22:51:13 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/2f8fbd24bde1

Note You need to log in before you can comment on or make changes to this bug.