[FEATURE] keyboard navigation doesn't work

VERIFIED WORKSFORME

Status

()

Core
Editor
P3
major
VERIFIED WORKSFORME
19 years ago
17 years ago

People

(Reporter: penny, Assigned: mjudge)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I am very used to mouse clicking the location box to type in a new URL.  In
Milestone 5, win32, when I do this I cannot move around in consistency with the
windows UI.

You should be able to click, and hit shift+end or shift+home to highlight and
all the type to the right or left of the cursor respectively.  No highlighting
occurs and it just doesn't work.  :(

I've also just discovered that my arrow keys on the keyboard don't work in this
text box I'm typing in right now either.  :(

Peace,
Penelope

Updated

19 years ago
Assignee: shuang → german
Target Milestone: M14

Comment 1

19 years ago
All keyboard navigation will start working, but in much later milestones. Set to
M15 for complete fixing.

Updated

19 years ago
Assignee: german → buster

Comment 2

19 years ago
This bug relates to keyboard nav inside ender fields. Forwarding to Steve Clark
so he can identify who's working on it right now.

Updated

19 years ago
URL: none
Component: UE/UI → Editor
OS: Windows 98 → All
QA Contact: sujay
Hardware: PC → All

Comment 3

19 years ago
This is probably a duplicate of a bug that Mike Judge has for M9; however, this
probably won't fix the location bar editbox until some later Milestone.

Updated

19 years ago
Assignee: buster → mjudge
Summary: keyboard navigation doesn't work → [FEATURE] keyboard navigation doesn't work

Comment 4

19 years ago
Added keyword "FEATURE" to summary.  This is a placeholder bug for functionality
that does not yet exist.  Assigned to mike judge.

Updated

19 years ago
Target Milestone: M14 → M9

Comment 5

19 years ago
setting to M9; Mike should have the keyboard navigation working by then
[currently line 195] and hopefully gfx widgets will land then too.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 6

19 years ago
this is the location box.  I will mark this as works for me. This later date
that I am looking at this it seems to be fixed.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
verified in 7/25 build.
You need to log in before you can comment on or make changes to this bug.