Last Comment Bug 745114 - B2G Wifi: trigger `onstatuschange' callbacks when the wifi status changes
: B2G Wifi: trigger `onstatuschange' callbacks when the wifi status changes
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Blake Kaplan (:mrbkap)
:
Mentors:
Depends on:
Blocks: b2g-wifi
  Show dependency treegraph
 
Reported: 2012-04-13 01:29 PDT by Fabien Cazenave [:kaze]
Modified: 2012-04-19 16:48 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (7.44 KB, patch)
2012-04-13 02:10 PDT, Blake Kaplan (:mrbkap)
cjones.bugs: review+
fabien: feedback+
Details | Diff | Splinter Review

Description Fabien Cazenave [:kaze] 2012-04-13 01:29:37 PDT
following bug 740079

To get along with the synchronous `status' property, it would be nice to support `onstatuschange' callbacks. There are a few use cases where this would be easier than a set of onconnect / onconnecting / ondisconnect / etc. event listeners and it would be more XHR-like.
Comment 1 Blake Kaplan (:mrbkap) 2012-04-13 02:10:19 PDT
Created attachment 614702 [details] [diff] [review]
Patch v1

This should be pretty straightforward. The one thing I wondered about was whether it was worth it to change the internal (IPC) notifications to follow the DOM API. I decided against it since not all of the notifications did exactly the same thing (in particular, disconnect is handled a little differently). Any opinions on that would be welcome.
Comment 2 Fabien Cazenave [:kaze] 2012-04-13 03:22:25 PDT
>+     *   - disconnected: Fires when we either fail to connect to an access
>+     *                   point (transition: onassociate -> ondisconnect) or
>+     *                   when we were connected to a network but have
>+     *                   disconnected for any reason (transition: onconnect ->
>+     *                   ondisconnect).

nit:
  transition: associated -> disconnected
  transition: connected -> disconnected
Comment 3 Fabien Cazenave [:kaze] 2012-04-13 06:47:28 PDT
Here’s a preliminary front-end:
https://github.com/andreasgal/gaia/pull/1226
Comment 4 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2012-04-19 08:26:47 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/1d3aea7115d3
Comment 5 Ed Morley [:emorley] 2012-04-19 16:48:54 PDT
https://hg.mozilla.org/mozilla-central/rev/1d3aea7115d3

Note You need to log in before you can comment on or make changes to this bug.