bugzilla's MIME type checking is too strict

VERIFIED DUPLICATE of bug 53696

Status

()

VERIFIED DUPLICATE of bug 53696
18 years ago
6 years ago

People

(Reporter: waterson, Assigned: justdave)

Tracking

Details

(Reporter)

Description

18 years ago
Thanks to the ever-vigilant standards champions, we no longer support
``text/xul'' as a MIME type. In it's place, ``application/vnd.mozilla.xul+xml''.
(See bug 28273, if you care.)

Unfortunately, Bugzilla thinks this MIME type is bullshit. (I happen to agree
with Bugzilla, but, what do I know.) Specifically, it reports, ``You must select
a legal mime type. 'application/vnd.mozilla.xul+xml' simply will not do.''

Could you please fix Bugzilla to accept the above mank? Thanks.
(Reporter)

Comment 1

18 years ago
Sorry, should be a bit more clear. I cannot specify the above mess as a MIME
type for an attachment. To reproduce:

1. Click on the ``Create a new attachment'' link.
2. Pick a file on your hard drive.
3. Enter ``application/vnd.mozilla.xul+xml'' as the MIME type

Expected: file is attached to bug
Actual: Bugzilla rejects attachment because of MIME type.


*** This bug has been marked as a duplicate of 53696 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
V.
Status: RESOLVED → VERIFIED
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Assignee: tara → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: Bugzilla 2.10 → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.